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** Troubleshooting ** "Failed to execute runnable ... Widget is disposed" when launching "System Audit - Browse'

Troubleshooting


Problem

User clicks 'Maintain - System Audit - Browse'. User receives error.

Symptom

Unexpected error: Something unexpected happened. You may have to restart the application to continue.
Reason:
[SWTException] Failed to execute runnable (org.eclipse.swt.SWTException: Widget is disposed)

Cause

There are several possible causes for this/similar error:

  • Scenario #1 - Invalid configuration inside application database
    • Specifically, there are pairs of accounts that are mapped to the same ids in the table 'xmapping'.
  • Scenario #2 - Invalid configuration inside application database
    • Specifically, there is an invalid/duplicate entry in extended dimensions
  • Scenario #3 - (RARE) Invalid/incorrect System Variable "CCR_JAVA_Home" on the Controller application server.

Diagnosing The Problem

Typically there is a useful message stored inside the 'ccr.log' file (on the Controller application server).

  • TIP: By default, this is located here: C:\Program Files\IBM\cognos\c10\log\ccr.log

Resolving The Problem

Scenario #1
In one real-life customer example, there were two pairs of accounts that are mapped to the same ids in the table xmapping. For example:

  • The accounts F12345678A and F23456789C are both mapped to the id 12345.
  • The accounts F876543210 and F765432105 are both mapped to the id 54321.

To fix this remove one of each pair of duplicated ids in the xmapping table. The system will automatically regenerate new IDs when the system is restarted.

Steps:
IMPORTANT:
  • Before trying the advice in this Technote, please raise a support call (SR/PMR) with IBM Support, so that we can give you specific advice to your scenario.
  • Proceed with the following steps at your own risk!

1. Obtain some downtime (no users on the system)
2. Create a backup of the database (as a precaution)
3. Launch the relevant database management tool (e.g. "SQL Server Management Studio")
4. Connect to the Controller database using the relevant SQL login (e.g. 'fastnet')
5. Run the following queries (modifying them as appropriate to your needs):

delete from xmapping where code = 'F876543210' and EntityTypeName = 'com.cognos.ccr.models.account.Account'
delete from xmapping where code = 'F23456789C' and EntityTypeName = 'com.cognos.ccr.models.account.Account'

6. When the application is started again new ids will be automatically generated for the account codes that now are missing ids.

Scenario #2
Remove or correct the duplicate entry in extended dimensions
  • For full details, see separate IBM Technote #1653790.

Scenario #3
Ensure that the System variable CCR_JAVA_Home is configured correctly. Afterwards, restart the Windows services "IBM Cognos Controller Java Proxy".
  • For full details, see separate IBM Technote #1615017.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21674566