Troubleshooting
Problem
You see an exception trace entry XSSB INQUIRE_USER_ATTRIBUTES/EXCEPTION PROFILE_UNKNOWN being written to the CICS trace. This occurs when you sign onto a CICS Transaction Sever for z/OS (CICS TS) region, either explicitly or by using a distributed identity. You might also notice CICS flooding SMF datasets with RACF related records.
Cause
A potential cause of this exception is that no CICS segment exists in the advanced communications function (ACF) user profile.
During signon processing, CICS will call the system ACF to determine the userid attributes. If a userid profile does not have a CICS segment, then an exception trace entry is written:
XS FE04 XSSB *EXC* INQUIRE_USER_ATTRIBUTES/EXCEPTION PROFILE_UNKNOWN
Resolving The Problem
If the userid does not have a CICS segment, but the signon operation completes successfully with the expected privileges, then it safe to ignore this trace entry.
A signon operation might happen either explicitly using console interaction, programmatically, or by the processing of a distributed identity.
To find out more about the information stored in the CICS segment, see The CICS segment topic, under RACF user profiles in the Securing section of IBM Knowledge Center.
Related Information
Product Synonym
CICS/TS CICS TS CICS Transaction Server
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Document Information
Modified date:
15 June 2018
UID
swg21672756