IBM Support

The BPMMigrate.sh command for IBM Business Process Manager (BPM) Advanced results in a "SOAPException:java.net.SocketTimeoutException: Read timed out error" message

Troubleshooting


Problem

When you attempt to upgrade from IBM Business Process Manager Advanced V8.0 to Version 8.5, you encounter a "SOAPException:java.net.SocketTimeoutException: Read timed out error" message when you run the BPMMigrate.sh command.

Symptom

You might see messages that are similar to the following text in the log files:

Mar 13, 2014 9:22:26 AM INFO:
com.ibm.bpm.migration.BPMMigration.migrate() - CWMCO1029I: Migration of
the adapter completed successfully.
Mar 13, 2014 9:22:26 AM INFO:
com.ibm.bpm.migration.BPMMigration.migrate() - CWMCO1014I: Start to
perform configuration synchronization of all custom nodes with the cell
repository.
Mar 13, 2014 9:25:27 AM WARNING:
com.ibm.bpm.migration.utils.BPMMigrationJMXHelper.syncAllCustomNodes()
- Failed to sync customer node psESPUATNode01.
com.ibm.websphere.management.exception.ConnectorException: ADMC0009E:
The system failed to make the SOAP RPC call: invoke
at
com.ibm.ws.management.connector.soap.SOAPConnectorClient.invokeTemplateO
nce(SOAPConnectorClient.java:889)
at
com.ibm.ws.management.connector.soap.SOAPConnectorClient.invokeTemplate(
SOAPConnectorClient.java:685)
at
com.ibm.ws.management.connector.soap.SOAPConnectorClient.invokeTemplate(
SOAPConnectorClient.java:675)
at
com.ibm.ws.management.connector.soap.SOAPConnectorClient.invoke(SOAPConn
ectorClient.java:661)
at
com.ibm.ws.management.connector.soap.SOAPConnectorClient.invoke(SOAPConn
ectorClient.java:483)
at com.sun.proxy.$Proxy7.invoke(Unknown Source)
at
com.ibm.ws.management.AdminClientImpl.invoke(AdminClientImpl.java:224)
at
com.ibm.bpm.migration.utils.BPMMigrationJMXHelper.syncAllCustomNodes(BPM
MigrationJMXHelper.java:1305)
at com.ibm.bpm.migration.BPMMigration.migrate(BPMMigration.java:566)
at com.ibm.bpm.migration.BPMMigration.doWork(BPMMigration.java:352)
at com.ibm.bpm.migration.BPMMigration.main(BPMMigration.java:130)
Caused by: [SOAPException: faultCode=SOAP-ENV:Client; msg=Read timed
out; targetException=java.net.SocketTimeoutException: Read timed out]
at
org.apache.soap.transport.http.SOAPHTTPConnection.send(SOAPHTTPConnection.java:479)
at org.apache.soap.rpc.Call.WASinvoke(Call.java:487)
at
com.ibm.ws.management.connector.soap.SOAPConnectorClient$8.run(SOAPConnectorClient.java:847)
at
com.ibm.ws.security.util.AccessController.doPrivileged(AccessController.java:118)
at
com.ibm.ws.management.connector.soap.SOAPConnectorClient.invokeTemplateOnce(SOAPConnectorClient.java:840)

Cause

If you are using a SOAP connection, the migration command can take longer to complete than the specified SOAP timeout value. You might see an exception like java.net.SocketTimeoutException: Read timed out.

Resolving The Problem

To prevent this problem, modify the value of the com.ibm.SOAP.requestTimeout property in the soap.client.props file.

  • If you installed the new version of the product on the same computer as the source environment, the file is found in the BPM_home_8.5/util/migration/resources/ directory.
  • If you installed the new version of the product on a different computer and copied the migration files to the source environment, the file is found in remote_migration_utility/util/migration/resources/ directory.

[{"Product":{"code":"SSFTN5","label":"IBM Business Process Manager Advanced"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Migration","Platform":[{"code":"PF016","label":"Linux"}],"Version":"8.5;8.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

BPM

Document Information

Modified date:
15 June 2018

UID

swg21668006