IBM Support

QRadar: Console may not display correctly in Internet Explorer

Troubleshooting


Problem

This technote describes a user interface issue that may be observed with multiple versions of Internet Explorer.

Symptom

If an administrator selects the Admin tab in the user interface (UI), they may not be able to navigate to other tabs until the browser configuration is updated.

This issue is linked to a display issue when the browser setting for Document mode is configured to an incorrect value.

Additional symptoms: administrators might notice that text typically located on the right-hand side of the screen is displayed much farther left than expected.

Text displayed incorrectly in Internet Explorer 8:


This issue has also been reported by administrators who use a Group Policy Object that restricts or sets the Document mode in Internet Explorer to an incorrect version.

Cause

An incorrect Document Mode value is configured in Internet Explorer.

Environment

QRadar 7.2 and 7.1

Diagnosing The Problem

To diagnose the issue, the user can verify the Document Mode settings in Internet Explorer.

  1. Open Internet Explorer.
  2. To open the Developer Tools, Press the F12 key.
  3. Verify the document mode is not configured for Internet Explorer 7 or another older version of Internet explorer.

Example of an incorrect browser setting:

Resolving The Problem

If the browser appears to be displaying the user interface incorrectly, the browser must be updated to use Document Mode for the appropriate version of Internet Explorer.

Browser VersionBrowser Mode SettingDocument Mode Setting
Internet Explorer 7 IE 7 IE 7 Standards
Internet Explorer 8 IE 8 IE 8 Standards
Internet Explorer 9 IE 9 IE 9 Standards

To diagnose the issue, the user can verify the Document Mode settings in Internet Explorer browser.

  1. Open Internet Explorer.
  2. From the browser menu, select About Internet Explorer to determine your browser version.
  3. To open the Developer Tools, Press the F12 key.
  4. From the Document Mode list, select the value that matches your Internet Explorer browser version.

    Example of a correct browser setting:

  5. The user interface is Internet Explorer is refreshed with the new Document Mode setting.

    Text displayed correctly in the user interface (click to enlarge):

Note: If the administrator of the Windows system has restricted access to the Developer Tools by applying a Group Policy Object (GPO), you must contact your
Windows administrator to update the GPO or allow QRadar users to configure Document mode values.

[{"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Admin Console","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.1;7.2","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21665587