IBM Support

Generating WebSphere MQ MSTR internal trace on IBM z/OS

Troubleshooting


Problem

This document details how to generate a WebSphere MQ MSTR internal trace on IBM z/OS in order to investigate a problem.

Cause

WebSphere MQ MSTR internal trace can help to determine why a problem is happening in the MSTR address space, whether the cause of the problem is in WebSphere MQ or the operating system. For other kinds of traces refer to:

Resolving The Problem

Before Tracing


Check the trace table (TRACTBL) size and status, and if necessary increase the size to capture the problem. To determine the trace table size and status, run the following commands, where /cpf refers to the command prefix for the WebSphere MQ subsystem:

    Checking the trace table size and status

    /cpf DISPLAY SYSTEM

    /cpf DISPLAY TRACE

You can increase the size of the trace by running the following command, where xxx is an integer from 1 to 999 (default: 99) indicating the number of 4K blocks to use:


    Setting the trace table size

    /cpf SET SYSTEM TRACTBL(xxx)

    /cpf DISPLAY TRACE

If any trace is currently in effect, the old trace table continues to be used and its size is unchanged. If there is insufficient storage for the new trace table, WebSphere MQ issues message CSQW153E and continues to use the old one. A new global trace table is obtained only for a new START TRACE command. For WebSphere MQ V7.0 and V6.0 you will need to apply a PTF or follow the local fix instructions:



Generating a WebSphere MQ MSTR Internal Trace


  1. Start trace using the command below, where /cpf refers to the command prefix for the WebSphere MQ subsystem:

    Starting MSTR internal trace


    /cpf
     START TRACE(GLOBAL) DEST(RES) CLASS(*) RMID(*)



  2. Recreate the problem, then capture the trace in a dump of the WebSphere MQ MSTR address space. In these examples, replace ssid with the subsystem id of your queue manager, and nn with the reply numbers from the IEE094D messages on your system:

    Dumping the MSTR and CHIN jobs and the CHIN trace data space (preferred)


    /DUMP COMM=(MQ MSTR & CHIN DUMP)
    /R nn,JOBNAME=(ssidMSTR,ssidCHIN),CONT
    /R nn,SDATA=(CSA,RGN,PSA,SQA,LSQA,TRT,SUM),CONT
    /R nn,DSPNAME=('ssidCHIN'.CSQXTRDS),END


    Dumping only the MSTR job


    /DUMP COMM=(MQ QUEUE MANAGER DUMP)
    /R nn,JOBNAME=(ssidMSTR),CONT
    /R nn,SDATA=(CSA,RGN,PSA,SQA,LSQA,TRT,SUM),END



    Check the syslog for an IEA611I or IEA911E message to be sure the dump is complete. Refer to the additional information below for examples which show how to include application jobs and coupling facility structures in the dump.


  3. Optionally, stop trace:

    Stopping MSTR internal trace


    /cpf STOP TRACE(GLOBAL) DEST(RES) CLASS(*) RMID(*)



  4. Format the trace. WebSphere MQ MSTR trace information can be displayed on-line or in batch, provided the WebSphere MQ dump formatting member has been included in SYS1.PARMLIB. Enter the following IPCS command, where ssid is the subsystem id:

    Formatting MSTR internal trace


    VERBX CSQWDPRD 'SUBSYS=ssid,TT'




  5. Additional Information



[{"Product":{"code":"SSFKSJ","label":"WebSphere MQ"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Problem Determination","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"8.0;7.1;7.0.1;6.0","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21665092