IBM Support

Clearing "Stuck online" IBM.AgFileSystem resource

Troubleshooting


Problem

AgFileSystem resource is "Stuck online". How can I clear that state without taking the AgFileSystem resource offline ?

Cause

The cause of the Stuck online state is not related to TSAMP product, so not discussed here.

Diagnosing The Problem

Here's an example of trace messages from the automation engine (IBM.RecoveryRM) trace summary file showing a resource Stuck online :

12/11/13 14:19:12.948093 T(3600) _RCD ReportState: Resource : db2homefs_node01/Fixed/IBM.AgFileSystem/node01 reported state change: 6
12/11/13 14:20:00.651926 T(3600) _RCD ReportState: Resource : db2homefs_node01/Fixed/IBM.AgFileSystem/node01 reported state change: 4

--> 6 = Pending offline, 4 = Stuck online

Resolving The Problem

Assuming the filesystem *is* mounted, to clear the state, issue the following command as root :

startrsrc -s "Name = 'db2homefs_node01' & NodeNameList={'node01'}" IBM.AgFileSystem

=> Substitute for your own resource and node names.

[{"Product":{"code":"SSRM2X","label":"Tivoli System Automation for Multiplatforms"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"3.2;3.2.1;3.2.2;4.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
24 June 2019

UID

swg21663568