IBM Support

Deploying Worklight applications in parallel fails with message "Service Unavailable"

Troubleshooting


Problem

Error message "SEVERE: Service Unavailable" occurs when running concurrent instances of the IBM Worklight plug-in component process step "Deploy Worklight Application to Worklight Server."

Symptom

The console log includes the following error message:

"[deployer] <date> com.worklight.ant.deployers.AbstractDeployerTask logDeployResponse


 [deployer] SEVERE: Service Unavailable;
An error occurred while deploying the Worklight application: deployer failed:SEVERE:Service Unavailable; ."

Cause

IBM Worklight 6.1.0 Server does not support concurrent deployments of Worklight applications.

Environment

IBM Worklight 6.1.0 Server.

Resolving The Problem

Modify the component process so that the "Deploy Worklight Application to Worklight Server" steps occur in serial order instead of concurrently (in parallel).

[{"Product":{"code":"SS4GSP","label":"IBM UrbanCode Deploy"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Integrations - IBM","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF022","label":"OS X"},{"code":"PF033","label":"Windows"}],"Version":"6.0;6.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21660300