IBM Support

Long startup time for the IBM Business Monitor server with IBM Business Process Manager (BPM)

Troubleshooting


Problem

If the IBM Business Monitor server is taking a long time to start, in the order of hours, there might be security software running on the system that causes a conflict with the file scanning operation in IBM Business Process Manager and IBM Business Monitor.

Symptom

In a combined profile with IBM Business Process Manager and IBM Business Monitor, if the system is running a security software, such as Digital Guardian, there might be an adverse impact on the server start time due to the following error:


Startup thread hang with WSVR0605W as below:  
WSVR0605W: Thread "server.startup : 1" (00000051) has been active for  
730750 milliseconds and may be hung.  There is/are 1 thread(s) in total  
in the server that may be hung.
at java.io.WinNTFileSystem.getBooleanAttributes(Native Method)  
at java.io.File.isDirectory(File.java:765)  
at org.eclipse.jst.j2ee.commonarchivecore.internal.strategy  
   .DirectoryLoadStrategyImpl.addNextFromBinariesDirectory  
   (DirectoryLoadStr ategyImpl.java:1369)  

The performance degradation occurs when the system scans a large enterprise archive (EAR) file with large number of sub directories and files, such as the Cognos.ear file.

Cause

The Digital Guardian software has a conflict with the file scanning operation in IBM Business Process Manager and IBM Business Monitor.

Environment

This issue is only observed in Microsoft Windows 7 running the Digital Guardian software.

Diagnosing The Problem

To diagnose the issue, see if the server takes an abnormal amount of time to start. You can also check if the following error message exists:

Startup thread hang with WSVR0605W as below:  
 WSVR0605W: Thread "server.startup : 1" (00000051) has been active for  
 730750 milliseconds and may be hung.  There is/are 1 thread(s) in total  
 in the server that may be hung.
 at java.io.WinNTFileSystem.getBooleanAttributes(Native Method)  
 at java.io.File.isDirectory(File.java:765)  
 at org.eclipse.jst.j2ee.commonarchivecore.internal.strategy  
    .DirectoryLoadStrategyImpl.addNextFromBinariesDirectory  
    (DirectoryLoadStr ategyImpl.java:1369)  

Resolving The Problem

To resolve the issue you can disable Digital Guardian, or configure Digital Guardian to allow IBM Business Process Manager and IBM Business Monitor to scan their own directories.

[{"Product":{"code":"SSFTN5","label":"IBM Business Process Manager Advanced"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Performance","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5;8.0.1;8.0;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SS7NQD","label":"IBM Business Monitor"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Performance","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.0;7.5","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}},{"Product":{"code":"SSFTDH","label":"IBM Business Process Manager Standard"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Performance","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5;8.0.1;8.0;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSFTBX","label":"IBM Business Process Manager Express"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Performance","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5;8.0.1;8.0;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

BPM

Document Information

Modified date:
15 June 2018

UID

swg21660162