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How to disable the use of a proxy server when using Controller

Troubleshooting


Problem

Customer's client device is configured to use a proxy server. This is causing problems in Controller.

How can they reconfigure the client device to not use the proxy server for connections to the Controller application server?

Symptom

There are many different problems/errors/symptoms that the users may see if they use a proxy server when connecting to the Controller application server.

  • For examples, see separate IBM Technotes.

Cause

Using a proxy server (between the client device and the Controller application server's website) is not supported by IBM.

More Information:
All communication between the Controller client and the Application server is via web traffic, to/from the application server's IIS webserver. [By default, this is HTTP traffic over TCP port 80].

By default, this communication will be governed by the settings chosen inside Microsoft Internet Explorer (IE).

  • Therefore, if MS IE is configured to use a Proxy server, then the Controller traffic will go though the proxy server.


IBM Cognos does not explicitly support the use of proxy servers between the client PCs and the application server - if customers choose to use a proxy server, then they do so at their own risk.

  • One of the reasons why IBM do not explicitly support the user of a proxy server is that there are many different types of proxy servers available (for example "Microsoft Proxy 2.0", Micosoft "ISA", "Squid" etc.).
  • Each proxy server has different capabilities/abilities, and therefore it is impossible to confirm that all proxy servers will be be able carry the network traffic that Controller requires successfully.


In other words:

  • Ideally, all customers should disable the use of proxy servers for Controller communication
  • However, some customers successfully use a proxy server for Controller communication
    • This is not supported by IBM Cognos, but it appears to work OK for these customers
If Controller works OK when the client device is configured to bypass the proxy server, then the customer should contact its I.T. department's proxy server administrator for assistance in configuring the proxy server to work
  • IBM Cognos cannot support this directly.

Diagnosing The Problem

There are several different ways to check if your client device is using a proxy server:

 

Method #1 (GUI)
1. Logon to the client device (for example desktop PC)
2. Launch Microsoft Internet Explorer
3. Click 'Tools - Internet Options':

4. Click 'Connections'
5. Click 'LAN Settings'

6. Locate the following settings:

  • 'Automatically detect settings'
  • 'Use automatic configuration script'
  • 'User a proxy server for your LAN...'


If all of these are unticked, then you are not using a proxy server.

  • However, if one (or more) of the above are ticked, then you may be using a proxy server.

Method #2 (Command Line)

1. Launch a command prompt

2. Type the following command:        netsh winhttp show proxy

Example (for a PC which is not using a proxy server):

image-20180709102504-1

Resolving The Problem

Consult your I.T. administrator to ensure that either:

(1) Disable the use of a proxy server completely

or (2) Ensure the Controller website (for example http://servername) is bypassed (in other words, proxy server not used for the Controller server's website address).

Steps:

NOTE:

  • The following instructions assume that the end user has the ability to change their settings inside Internet Explorer. In some environments (typically Citrix/Terminal Server environments) this may not be possible. In this case, ask your I.T. department for assistance.
  • Choose whichever of the following two solutions (1 or 2) is best for your environment.

Solution #1 - Disable the use of a proxy server completely

There are two methods to achieve this. Decide on which one is best for your environment:

 

  • Method A - Disable proxy server inside Internet Explorer (affects all software that uses IE)

1. Logon to the client device (for example desktop PC)
2. Launch Microsoft Internet Explorer
3. Click 'Tools - Internet Options'
4. Click 'Connections'
5. Click 'LAN Settings'
6. Untick *all* of the following settings:

- Automatically detect settings
- Use automatic configuration script
- User a proxy server for your LAN...
   
  • Method B - Disable proxy server for Controller only

This method can be the easiest for many customers, although it may not work in all environments.

1. Logon to the client PC

2. Launch Windows Explorer

3. Browse to the folder containing the file CCR.EXE

  • TIP: By default this is here:      C:\Program Files\IBM\IBM Cognos Controller Local Client


4. Open the file "CCR.exe.config" inside NOTEPAD.EXE

5. Add the following text (see below highlighted in bold) just above the final line ("</configuration>")...

    
<system.net>
<defaultProxy>
<proxy usesystemdefault="false"/>
</defaultProxy>
</system.net>

    

...so that the file looks something similar to:

 

6. Browse to the folder containing EXCEL.EXE

  • TIP: By default, for Excel 2003 this is: C:\Program Files (x86)\Microsoft Office\OFFICE11

7. Open the file "EXCEL.EXE.config" inside NOTEPAD.EXE

8. Add the following text (see below highlighted in bold) so that the file looks something similar to:

<configuration>
<startup>
<supportedRuntime version="v2.0.50727"/>
</startup>
 
<runtime>
<generatePublisherEvidence enabled="false"/>
</runtime>
 
<system.net>
<defaultProxy>
<proxy usesystemdefault="false"/>
</defaultProxy>
</system.net>
 
</configuration>

 

9. Save changes and test.

  

Solution #2 - Ensure the Controller website (for example http://servername) is bypassed

TIP: See separate IBM Technote #1347832 if you are using a proxy.pac configuration file.

Before continuing, it is vital to check what the *exact* value of the web server's name is being used by the Controller client.
To do this:

  1. Logon to the client device as the end user
  2. Click 'Start - Run'
  3. Type: %APPDATA% <Enter>
  4. Open the subfolder "cognos"
  5. Open the subfolder "ccr"
  6. Open the file "ccr.config" inside NOTEPAD.EXE
  7. Search for the lines similar to:
  • <add key="CASUrl" value="http://myservername/cognos8/controllerbin" />
  • <add key="WSSUrl" value="http://myservername/cognos8/controllerserver" />
  • <add key="HelpUrl" value="http://myservername/cognos8/ControllerHelp"


This clearly shows the value of the Controller application server's website.

IMPORTANT: Ensure that you choose the correct form (NetBIOS or FQDN) of the website name!

  • It is *vital* that you use the same server-naming convention
    • in the above case it is the 'NetBIOS' name
    • This is different from the FQDN name would be something like http://COL43-5414-2609.mycompany.com/ibmcognos/controllerbin

After checking the above, logon to the client PC/device as the 'bad' end user

  1. Launch Internet Explorer
  2. Click 'tools' - 'Internet Options' - 'Connections' - 'LAN settings'
  3. Click on 'advanced'
  4. Locate the box 'Exceptions - do not use proxy server for addresses beginning with:'
  5. Add an entry for the Controller website (see below for example):

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
18 December 2019

UID

swg21655498