IBM Support

Cannot install Cognos Insight or Performance Modeler in Cognos Express

Troubleshooting


Problem

In IBM Cognos Express, you cannot install Cognos Insight or Performance Modeler.

Symptom

When you try to launch Cognos Insight or Performance Modeler in Express for the first time, the following message appears:

The system administrator has set policies to prevent this installation.

Cause

This issue is caused by default security settings on Windows 2008 and Windows 2012 computers. The User Account Control (UAC) settings specify that non-administrators cannot run Microsoft Installer (.msi) files.

Environment

This issue applies to IBM Cognos Express releases 10.2.1.0, 10.2.1.1, 10.2.1.2, 10.2.1.3, and 10.2.1.4.

Resolving The Problem

To resolve this issue, follow these steps:

  1. Go to Start > Accessories.
  2. Right-click Command Prompt and select Run as administrator.
  3. In the command window, use the cd command to go to the directory containing either CognosInsight.msi or PerformanceModeler.msi.
  4. Type either CognosInsight.msi or PerformanceModeler.msi.

The product installs and launches.

[{"Product":{"code":"SSDL22","label":"IBM Planning Analytics Express"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
10 November 2022

UID

swg21653926