IBM Support

"The request failed with HTTP status 405: Method Not Allowed" when launching Controller, caused by incorrect 'Controller URI for gateway' settings

Troubleshooting


Problem

User launches Controller client. User receives error.

Symptom



Error
An error occurred while trying to access the server.
http://servername/ibmcognos/cgi-bin/cognos.cgi?t=controller
[Details] [OK]

Error Details
The request failed with HTTP status 405: Method Not Allowed.

Cause

There are several possible causes of the same symptoms.

  • TIP: See separate IBM Technote #1653361 for more examples.

This Technote specifically relates to the scenario where the cause is that the administrator has incorrectly configured the setting "Controller URI for gateway" inside "Cognos Configuration" on the Gateway server.

Example:
In one real-life customer example, the administrator had forgotten to add the entry "ccrws.asmx" to the end of the entry.

Environment

Controller is configured to use a dedicated 'gateway' machine (for example located in the DMZ) which is separate from the 'main' Controller application server.

  • In other words, the system is configured in the way described inside separate IBM Technote #1367311.

Resolving The Problem

Modify the setting for "Controller URI for gateway" to the correct value, for example:


Steps:
1. Logon to the Gateway server as an administrator
2. Launch "Cognos Configuration"
3. Inside "Environment", locate the setting for "Controller URI for gateway"
4. Modify this setting to have the correct value (including the ending), for example: http://APPSERVER:80/ibmcognos/controllerServer/ccrws.asmx


5. Press "Save"
6. Test.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21653498