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Setting the reverse proxy configurations when connecting to Business Space using a proxy server

Troubleshooting


Problem

If you use a proxy server to connect to Business Space, you need to verify that the reverse proxy configuration parameters are set.

Symptom

Business Space exhibits the following behaviors:

  • Business Space works when it is accessed directly
  • Business Space works when it is accessed by its IP address through a proxy server
  • Business Space fails when it is accessed by its hostname through a proxy server

Cause

This issue occurs when the reverse proxy configuration parameters are not set.

Environment

All

Diagnosing The Problem

Check if the following conditions exist:

  • Business Space works when it is accessed directly
  • Business Space works when it is accessed by its IP address through a proxy server
  • Business Space fails when it is accessed by its hostname through a proxy server

Resolving The Problem

You need to make sure that the following properties are set:

1. <Profile root>/<Profile name>/BusinessSpace/......../mm.runtime.prof/config/ConfigService.properties:
Description: This property defines the host name that the server will use when computing URLs returned to the client. This parameter should be used in conjunction with the reverseProxyPort parameter.


2. reverseProxyHost = <reverse proxy/http server hostname>
Description: This property defines the port that the server will use when computing URLs returned to the client. This parameter should be used in conjunction with the reverseProxyHost parameter
reverseProxyPort = <reverse proxy/http server port>.

3. Run the command updatePropertyConfig in the wsadmin environment of the profile:
$AdminTask updatePropertyConfig {-serverName server_name -nodeName node_name -propertyFileName "profile_root\BusinessSpace\node_name\server_name\mm.runtime.prof\config\ConfigService.properties" -prefix "Mashups_"}

4. run $AdminConfig save.

5. Synchronize the nodes.

6. Restart the servers and the deployment manager with config.bat update-was-config, and restart the server.

[{"Product":{"code":"SSSRR3","label":"WebSphere Business Monitor"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"7.0.0.5;7.0.0.4;7.0.0.3;7.0.0.2;7.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SS7NQD","label":"IBM Business Monitor"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"7.5.1;7.5","Edition":"","Line of Business":{"code":"LOB36","label":"IBM Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21651160