IBM Support

Installation of OMNIbus FP8 fails with "Incorrect install location”

Troubleshooting


Problem

Attempt to install IBM Netcool/OMNIbus FP8 (7.3.0-TIV-NCOMNIbus-linux2x86-FP0008) results in error: "Incorrect install location. The path you entered did not have any Netcool/Omnibus components installed. Please check and try again"

Cause

Seems user did non-root install originally but carried out OMNIbus FP8 installation as root.

Environment

IBM Netcool/OMNIbus 7.3.0 with IBM Deployment Engine (DE), non-root installation

Diagnosing The Problem

Review which user performed the base/previous installation - mostly, a non-root user.

Ensure that you have a back-up server with same environment/installation.

Resolving The Problem

Please follow the workaround noted below to resolve the issue :

1. Take backup of DE from backup server using command below:


"<DE_INSTALL_LOCATION>\bin\de_backupdb -bfile backupFile"


2. Copy the DE "backupFile" from backup server to primary server.

3. Please take backup of the "/usr/ibm/common/acsi/repos", copy repos folder to some other location in primary server.

4. Restore DE backup on primary server using command below:


"/usr/ibm/common/acsi/bin/de_restoredb -bfile backupFile"


4. Now, re-try the FP installation

[{"Product":{"code":"SSRLR8","label":"Tivoli Components"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Tivoli Deployment Engine","Platform":[{"code":"PF016","label":"Linux"}],"Version":"1.4","Edition":"All Editions","Line of Business":{"code":"","label":""}},{"Product":{"code":"SSSHTQ","label":"Tivoli Netcool\/OMNIbus"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"PF016","label":"Linux"}],"Version":"7.3.0","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

DE

Document Information

Modified date:
17 June 2018

UID

swg21650591