IBM Support

Why is the IBM Datacap Job Monitor dropdown list turning into an edit box?

Troubleshooting


Problem

Using TMWeb.Net, on the Job Monitor tab there are various dropdown controls. For APT, the default controls are Job, Task, Status, Operator and Station, although more or less can be visible due to customization. When processing large amounts of batches, it was noticed that some of the dropdown controls were changing to edit boxes and the data was no longer visible.

Cause

The number of items in the list exceeded the defined limit, causing the change of the dropdown control to the edit box control. This is by design. The setting determines the cut-off and defaults to 100

Resolving The Problem

Increase the limit that the control can handle by adding or changing the following in the \Datacap\tmweb.net\apps.ini file:

[YourAppName]

JMDropDownLimit=XX

where XX represents the number of items in the list.

Please note that actual quantity displayed will be slightly less, do to external factors. In some testing, a maximum 98 items were displayed when the limit was set to 100, so please test and adjust accordingly.

[{"Product":{"code":"SSZRWV","label":"IBM Datacap"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.1.0;8.0.1;8.0.0;7.6;7.5 SP1;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21648528