IBM Support

Verifying connectivity between the CONTROLLER and a zCentric agent

Troubleshooting


Problem

There are two separate HTTP (or HTTPS) communication paths between the TWSz CONTROLLER and a zCentric agent or DDM, inbound and outbound. The connection must unobstructed in both directions.

Cause

Various messages such as EQQHT15E and EQQHT43I may be issued and the workstation set OFFLINE if there is a blockage (such as a firewall) between the CONTROLLER and zCentric agent or Dynamic Domain Manager.

Diagnosing The Problem

Basic connectivity between two systems can be checked by PINGING in both directions.
.
To determine whether it is possible to access a specified port, one can attempt to telnet directly to that port. For instance:
>
> telnet <Host or IP> <port number>
>
> telnet phoenix.mylab.somewhere.ibm.com 31111
>
If the open attempt is rejected by the host, then either there is no listener at the specified port, or there is something blocking access to that port.

One can tell if anything is listening on a given port by issuing a NETSTAT command. For instance:
>
> netstat -an | grep 31114
>
Or on Windows
>
> netstat -an | findstr 31114
>

Resolving The Problem

Ensure there are no firewalls blocking the specified ports and that there is no conflict on those ports with other tasks.

[{"Product":{"code":"SSRULV","label":"IBM Workload Scheduler for z\/OS"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions;Version Independent","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Document Information

Modified date:
13 September 2019

UID

swg21644448