IBM Support

Collect troubleshooting data for Dynamic Scripting problems in CICS TS for z/OS 5.1 or higher

Troubleshooting


Problem

You are having a problem with the CICS Dynamic Scripting Feature Pack V2.0 for CICS Transaction Server for z/OS (CICS TS) V5.1 or later. You would like to know what documentation you must collect (MustGather) so that the CICS Support team can diagnose your problem. If you gather this documentation before contacting support it will expedite the troubleshooting process, and save you time.

Cause

A Dynamic Scripting problem in CICS can occur for many different reasons. The most common problems are documented under Troubleshooting and Support for CICS Dynamic Scripting Feature Pack in the CICS TS V5.1 information center.

Resolving The Problem

For the most up-to-date documentation, refer to Collecting CICS troubleshooting data (MustGather) for IBM Support in the CICS TS documentation. You will find the General information that you should gather for every type of problem followed by the Component-specific information that includes Troubleshooting data for Dynamic Scripting problems in CICS TS 5.1 or later.

The following is the original MustGather information:

Collect this MustGather data before contacting IBM Support:







Collecting general information for all problems


If you have already contacted IBM Support, you can continue on to the component-specific MustGather information. Otherwise, go to Collect troubleshooting data for CICS products - Read first.






Collecting data for problems with Dynamic Scripting

Gather the following documentation for your Dynamic Scripting problem and call IBM support:



Required (MustGather) data:
  • Trace and dumps under JVMServer workdir:

    <workdir>/javacore* [any java™ core dumps]
    <workdir>/Snap* [any java snap dumps]
    <workdir>/p8trace* [any p8 trace files]

  • If available, the JVM server standard out, standard error and trace files. These files are created in the JVM server working directory. The JVM server working directory is the directory defined in the work_dir parameter in the JVM server profile.

    The files are named:

    applid.JVMServer.Dyyyymmdd.Thhmmss.dfhjvmout
    applid.JVMServer.Dyyyymmdd.Thhmmss.dfhjvmerr
    applid.JVMServer.Dyyyymmdd.Thhmmss.dfhjvmtrc

    where applid is the APPLID of the CICS region and JVMServer is the name of the JVMSERVER resource.
  • If available, provide the CICS transaction dump and CICS system dump.
  • Provide the contents of your Liberty server profile directory. This directory is specified by WLP_OUTPUT_DIR in JVM server profile. By default, it is created in the JVM server working directory <workdir>/$APPLID/$JVMSERVER/wlp/usr/servers/server_name, replacing the symbols with runtime values.



Optional (MustGather) data:

If support requests more detailed logging:
  • Run CICS transaction CETR to activate tracing and logging information by setting AP and SJ component level to ALL. Rerun your applications. More logging and trace information will be dumped in dfhjvmtrc.
  • Provide the contents in <workdir>/$APPLID/$JVMSERVER/*.xapictrace [any xapic trace files], if the SJ component level is set to 3 or higher.
  • Provide the contents of your JVM profile directory. This directory is defined by the JVMPROFILEDIR system initialization parameter in your CICS region.
  • Provide JESMSGLG and MSGUSR, for messages that are issued by CICS.







Troubleshooting hints and tips

Diagnostic tips:
  • Review the logs and dumps generated at the point of failure.
  • Search the CICS support site for known problems using symptoms like the message number and error codes.
  • If you find a fixing PTF, see Ordering CICS products and maintenance for the options that are available to order CICS maintenance.
  • Gather the documentation and work with the CICS support team to resolve your problem.

Learn more about CICS Dynamic Scripting:






Exchanging data with IBM Support
  1. See Exchanging information with IBM Technical Support for FTP and email instructions using the IBM Enhanced Customer Data Repository (ECuRep).
  2. Go to the Service Request page to open or update a problem. If you have a SoftwareXcel enterprise edition for zSeries contract, you can also ask a non-defect installation and usage questions.

    Note: Always update your Service Request (problem record) to indicate that data has been sent.

If you need to speak to an IBM technical support representative call your country representative. If you need to speak to an IBM technical support representative in the US, call 1-800-IBM-SERV.

[{"Product":{"code":"SSGMGV","label":"CICS Transaction Server"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Dynamic Scripting","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"5.1;5.2;5.3;5.4","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Product Synonym

CICS/TS CICS TS CICS Transaction Server

Document Information

Modified date:
15 June 2018

UID

swg21643652