IBM Support

An "Administrative user name is required" error occurs during the installation process for IBM Business Process Manager (BPM) Advanced - Process Server

Troubleshooting


Problem

When you attempt to create a profile during the installation process for the Process Server for IBM Business Process Manager Advanced, an "Administrative user name is required" error occurs.

Symptom

The Installation Manager log file contains the following entry:


Silent installation fails with the following errors in the Installation Manager log file:
<result><warning>
  The packages currently installed at /opt/IBM/WebSphere have installed translations that are not supported by IBM® Business Process Manager Advanced V7.5 - Process Server package.  English text displays for unsupported translations.

</warning><error uid="CRIMA1075E">
  Error during "install" phase:

</error><error uid="CRIMA1075E">
  Unable to find custom install operation com.ibm.ws.exec.command.Exec

A package has an issue that cannot be resolved by Installation Manager.

Identify the package that has the issue by looking at the installation history. In Installation Manager, click File > Installation History. In console mode, enter S: View Installation History. Contact IBM customer support.

java.lang.ClassNotFoundException: com.ibm.ws.exec.command.Exec

</error><error>
  Administrative user name is required.

</error><warning>
 
Configuration errors were detected during the installation.  You should view the log files to investigate the severity of the errors. For more details, refer to this log file: <missing argument>

</warning><warning>
 
Configuration errors were detected during the installation.  You should view the log files to investigate the severity of the errors. For more details, refer to this log file: <missing argument>

</warning></result>

Cause

The silent installation response file includes the feature to create a profile (wps.profile.feature or esb.profile.feature). However, it does not include the key value pair for the administrative user ID and password.

Environment

This issue is not applicable to IBM Business Process Manager Advanced (non-Process Server installation), which does not have the feature to create profiles during a binary installation.

Resolving The Problem

The IBM Business Process Manager - Process Server installation image has the option to create a test server during a binary installation. If you chose to create a profile by adding the "wps.profile.feature" feature, then you must provide an administrative user name and password for the profile. If you do not add the required user name and password, you see the previously mentioned error during the installation process.


To correct the issue, complete one of the following processes:
  • If you need the profiles to be created during the binary installation, in the silent Installation response file, un-comment and customize the key value pair for the following options:
    • user.bpm.admin.username
      This value is the user name for the administrative console. It is needed if you are creating a profile.

    • user.bpm.admin.password
      This value is the password for the user.bpm.admin.username property. This property is needed if you are creating a profile.


      The following code is a sample response file:
      - <profile installLocation="/opt/IBM/BPM751" id="IBM Business Process Manager Advanced ProcessServer ">
       <data key="eclipseLocation" value="opt/IBM/BPM751" />
       <data key="cic.selector.nl" value="en" />
       <data key="user.import.profile" value="false" />
       <data key="user.select.64bit.image,com.ibm.websphere.ND.v70" value="false" />
      - <!--
      ###################################

         <data key='user.bpm.admin.username' value='admin'/>
         <data key='user.bpm.admin.password' value='adminpassword'/>

      #####################################
      -->
      </profile>
      <install modify="false">
         <offering profile="IBM Business Process Manager Advanced - Process Server" version="7.5.1001.20120915_1230" id="com.ibm.ws.WBPMPS" features="wps.client.feature,wps.server.feature,wps.profile.feature,esb.profile.feature"/>
      </install>


  • If you do not need the profiles to be created during the binary installation, remove the creation feature by deleting the wps.profile.feature and esb.profile.feature entries from the install element in the response file. For example:
    <install modify="false">
       <offering profile="IBM Business Process Manager Advanced - Process Server" version="7.5.1001.20120915_1230" id="com.ibm.ws.WBPMPS" features="wps.client.feature,wps.server.feature
    ,wps.profile.feature,esb.profile.feature"/>
    </install>

For more information, see the Installing IBM Business Process Manager Advanced: Process Server silently using the command line topic in the information center.

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Product Synonym

BPM

Document Information

Modified date:
15 June 2018

UID

swg21642029