Troubleshooting
Problem
When the Enterrprise Bundle Archive (EBA) is restarted, the archive might fail to initialize correctly.
Cause
There is a known issue in the underlying application framework infrastructure that prevents a clean restart of the EBA.
Diagnosing The Problem
The SystemOut.log file and the FFDC log files will show that the application did not start correctly.
The SystemOut.log will show log lines similar to the following:
The SystemOut.log will show log lines similar to the following:
- Trying to load native library mad...failed (library is loaded by another defunct classloader), retrying 60s remaining)
Resolving The Problem
The IBM Websphere Application Server instance that is hosting the application must be restarted.
You may also wish to try just simply undeploying the CBA(s) from within the Websphere console, and then redeploying. One of our customers reported that after following this simple process, the issue was resolved.
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Document Information
Modified date:
27 April 2022
UID
swg21639888