Troubleshooting
Problem
Deploying a configuration to an MDM operational server already configured with a different configuration can fail
Symptom
When deploying a configuration to an MDM operational server that has already been configured with a different configuration may fail. When the deployment fails a dialog box may appear with the message "Deployment failed because of an unknown error." The status of the Deploy Configuration job in the Jobs view will have a status of FAILED. If there are any errors in the configuration project they should be corrected before deploying again.
Cause
When a configuration is deployed, there are additional tables created that are not a part of the normal dictionary created by the configuration. Those additional tables (such as history tables and entity tables) are not deleted because they are created during the operation of the server and would result in a potential loss of data. The use case that is supported is for minor incremental changes to the configuration. However, major changes to the configuration such as renaming entity types cannot be supported without reinitializing both the database used by the server and the server itself.
Diagnosing The Problem
The server log may contain errors related to extra or "unexpected" records for some segment types, errors concerning attribute types with respect to history tables and errors related to unknown entity types. Errors related to unknown entity types are good indication that there was a configuration previously deployed on the server.
Resolving The Problem
When deploying a configuration from Workbench onto a server with an existing configuration you should first reinitialize the server. Stop the server, drop all of the tables in the database used by the server, run "madconfig bootstrap_instance" to reinitialize it and restart the server. You should then be able to redeploy the configuration.
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Document Information
Modified date:
27 April 2022
UID
swg21639690