IBM Support

IBM Business Process Manager (BPM) Advanced migration errors occur and the default Process Portal templates and spaces are not loaded

Troubleshooting


Problem

After you migrate IBM Business Process Manager servers and the IBM Business Process Manager database to V8.5.0, a database communication error is seen.

Symptom

The following errors are reported when the server starts:
com.ibm.mm.server.persistence.rdbms.dao.ibatis.BaseDaoreadPathByPath BMWSD0429E: An SQLException was encountered while communicating with the database.  Error code: 0, SQL State:  null, Message:  Error: executeQueryForObject returned too many results.

The default Process Portal spaces and templates are not loaded.

Cause

Multiple nodes in the cell attempt to load the default spaces and templates.

Resolving The Problem

If you have an environment with the Business Space component (for Process Portal) installed on multiple managed nodes in a cell, start only one node first and start the other nodes only after the first node has already started.

[{"Product":{"code":"SSFTN5","label":"IBM Business Process Manager Advanced"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Migration","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"8.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

BPM

Document Information

Modified date:
15 June 2018

UID

swg21638941