IBM Support

Changes to IBM Business Process Manager (BPM) users are not visible after the server is restarted

Troubleshooting


Problem

Changes to built-in, file-based repositories are not automatically replicated to managed nodes in a federated repositories configuration. You need to use the administrative console to replicate the changes you make to a built-in, file-based repository.

Symptom

When you create or modify a user name or password in the file-based repository from the Process Administration Console or the WebSphere Administration Console, the changes are not visible after the server is restarted.

Cause

The network deployment support in a federated repositories configuration only updates the in-memory state of the processes that are running on the managed nodes. Because WebSphere Application Server synchronizes the file systems, the network deployment support does not attempt to update the file systems of the managed nodes.

Changes to built-in, file-based repositories are not automatically replicated to managed nodes in a federated repositories configuration. You need to use the administrative console to replicate the changes you make to a built-in, file-based repository.

Resolving The Problem

You must synchronize the node configuration to replicate the changes to the built-in, file-based repository.

1. In the administrative console, click System Administration > Nodes to access the Nodes panel.

2. On the Nodes panel, select all the relevant nodes for which the changes to the built-in, file-based repository need to be made.

3. Click Full Resynchronize. The resynchronize operation resolves conflicts among configuration files and can take several minutes to complete.

After completing these steps, your federated repository configuration of managed nodes reflects the changes to the built-in, file-based repository.

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Product Synonym

BPM

Document Information

Modified date:
15 June 2018

UID

swg21637983