Question & Answer
Question
Steps to enable tracing with Tivoli Storage Manager for Virtual Environments to assist with troubleshooting backup and restore of VMs.
Cause
During problem determination, the logs are sometimes not sufficient to troubleshoot an issue. Here are the steps to enable tracing.
Answer
Enable tracing:
1. Edit the "dsmvddk.opt" file and enable trivia tracing by editing those 2 lines and putting a value of 6:
(take a note of the original value to change it back after)
1. Edit the "dsmvddk.opt" file and enable trivia tracing by editing those 2 lines and putting a value of 6:
vixDiskLib.transport.LogLevel = "6"
vixDiskLib.nfc.LogLevel = "6"
(take a note of the original value to change it back after)
dsmvddk.opt default locations:
IBM Spectrum Protect data mover client 7.1.x: C:\Program Files\Tivoli\TSM\baclient
IBM Spectrum Protect data mover client 8.1.x: C:\Program Files\Common Files\Tivoli\TSM\IBMVDDK
2. Edit the dsm.opt (or the option file used for VM operations) and add these 2 lines:
Recreate the problem:
Once tracing has been enabled, perform the operation that is failing. It can be a backup or a restore. To minimize the size of the trace, only perform the backup or restore of the VM that has the failure.
Once the problem has been recreated, please undo the changes done in step 1 and 2.
For the involved data mover and/or mount proxy node, run the following command :
For example :
The command will generate the dsminfo.txt and dsmmsinfo.txt files.
Collect data:
- c:\program files\tivoli\tsm\baclient\tsmve.trc
- c:\program files\tivoli\tsm\baclient\dsminfo.txt
- c:\program files\tivoli\tsm\baclient\dsmmsinfo.txt
As well as data outlined here:
http://www-01.ibm.com/support/docview.wss?uid=swg21497489
IBM Spectrum Protect data mover client 7.1.x: C:\Program Files\Tivoli\TSM\baclient
IBM Spectrum Protect data mover client 8.1.x: C:\Program Files\Common Files\Tivoli\TSM\IBMVDDK
2. Edit the dsm.opt (or the option file used for VM operations) and add these 2 lines:
traceflag tid pid enter exit general vm
tracefile tsmve.trc
Recreate the problem:
Once tracing has been enabled, perform the operation that is failing. It can be a backup or a restore. To minimize the size of the trace, only perform the backup or restore of the VM that has the failure.
Once the problem has been recreated, please undo the changes done in step 1 and 2.
For the involved data mover and/or mount proxy node, run the following command :
dsmc query systeminfo -optfile="<path\datamover node client option file name>"
For example :
cd "C:\Program Files\Tivoli\TSM\baclient"
dsmc query systeminfo -optfile=dsm.MYVE_DATACENTER_DM.opt
The command will generate the dsminfo.txt and dsmmsinfo.txt files.
Collect data:
- c:\program files\tivoli\tsm\baclient\tsmve.trc
- c:\program files\tivoli\tsm\baclient\dsminfo.txt
- c:\program files\tivoli\tsm\baclient\dsmmsinfo.txt
As well as data outlined here:
[{"Product":{"code":"SSERB6","label":"IBM Spectrum Protect for Virtual Environments"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Data Protection for VMware","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]
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Document Information
Modified date:
25 January 2019
UID
swg21636569