IBM Support

'User XXX already logged in to this database' when using (non-native) Cognos security (CAM)

Troubleshooting


Problem

Under certain scenarios, user receives error message when using Controller. These are triggered if the user leaves the Controller application idle for some time (longer than the timeout specificed inside "Cognos Configuration") and then (afterwards) tries to perform some tasks in Controller.

Symptom

Example #1:

  • User clicks "Maintain - user - manage active users". A new login window pops up (before the user has enough time to login).
  • If the user clicks "cancel" (to that login screen) Controller shows the user as logged off (logged out). However, in fact the user is stuck in the Controller session (you can see the user shows in list in manage active user)
  • If user try to log in again, error shows "user xxx already logged in to this database"

Example #2:
  • Inside Controller, user clicks ""Reports - Run".
  • User selects a report, and tick Excel Link, Send to application
  • User then waits (e.g. for over an hour) until the Cognos timeout has elapsed.
  • User now tries to open a different report (from the Controller menu)
  • The login window will popup
    • If the user clicks "Cancel" then an error message will appear followed by a message stating “The user is already updating this report”.

Cause

There are many potential causes for errors like these.

  • TIP: For a list of scenarios, see separate Technotes #1347869 & 1346879.

This Technote specifically relates to the scenario where the cause is a code production problem (APAR PM80524) in Controller.

Environment

This issue only affects customers who use non-native security - in other words, the customer uses Cognos ("CAM") security authentication.

Resolving The Problem

Upgrade to Controller 10.1.1 FP2 (10.1.2155) or later.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1;10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21636052