Troubleshooting
Problem
When you try to install or ugrade your DB2® product to DB2® 9.7 FP8 on Windows®, the installation fails because the cabinet file BASE0000.cab has an invalid signature.
Symptom
The installation log file contains this message :
MSI (s) (BC:C0) [15:20:22:046]: Validating digital signature of file
'I:\DB2\US\970\X64\UNIVER~1\db2\Windows\BASE0000.cab'
MSI (s) (BC:C0) [15:20:22:062]: File
'I:\DB2\US\970\X64\UNIVER~1\db2\Windows\BASE0000.cab' is not trusted.
WinVerifyTrust returned 0x800B010A
MSI (s) (BC:A0) [15:20:22:062]: Note: 1: 1330 2:
I:\DB2\US\970\X64\UNIVER~1\db2\Windows\BASE0000.cab 3: 266
MSI (s) (BC:A0) [15:20:22:062]: Product: DB2 Advanced Enterprise Server
Edition - DB2COPY1 -- Error 1330.A file that is required cannot be
installed because the cabinet file
I:\DB2\US\970\X64\UNIVER~1\db2\Windows\BASE0000.cab has an invalid
digital signature. This may indicate that the cabinet file is corrupt.
Error 266 was returned by WinVerifyTrust.
Error 1330.A file that is required cannot be installed because the
cabinet file I:\DB2\US\970\X64\UNIVER~1\db2\Windows\BASE0000.cab has an
invalid digital signature. This may indicate that the cabinet file is
corrupt. Error 266 was returned by WinVerifyTrust.
Cause
Starting with DB2® 9.7 FP8 a new certificate is used to sign the files.
Environment
DB2 version 9.7 on Windows® operating systems
Diagnosing The Problem
Run certmgr.msc from the Windows® command line and check if under "Trusted Root Certification Authorities" you have the certificate "VeriSign Class 3 Public Primary Certification authority - G5"
Resolving The Problem
You can use of the following solutions :
- Import the certificate from a Windows® server that has this certificate.
- Download it from https://www.symantec.com/page.jsp?id=roots and import it to the correct location.
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Document Information
Modified date:
16 June 2018
UID
swg21633808