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Snapshot deployment for IBM Business Process Manager (BPM) fails, but returns a success message

Troubleshooting


Problem

When you deploy a snapshot to a Process Server, you see a message that the snapshot deployment was successful. However, after you refresh the console or check the database, there is no evidence that the snapshot has been installed.

Symptom

You see the first two of the following symptoms and you might see the third symptom:

  • An error occurs that sets the transaction for rollback without raising an exception to the snapshot deployment process.

  • You see the following message on the Process Center even though the snapshot is not installed:
    CWLLG0156I: MySnapshot Install succeeded

  • You might see the following informational message during the deployment process on the Performance Data Warehouse server:
    WTRN0080W:  Transaction  IBM_BPM_PerformanceDW_MyTopologyPS.Support#twperfsvr-ejb.jar#APIServices 0000013CCB0E26FE0000000100000169A32CD3B564C71B97B0A0CF46DC8ACCF0AC016240
    0000013CCB1017A400000001000000306AA7B67343863FDA2347B8BBBEFDC9AA9C329CD0
    00000001 has timed out due to no client activity for greater than 60 seconds.

Cause

This issue also can be caused by any error that sets the transaction to roll back without raising an error. It might be any underlying code that catches an error rather than re-throwing it to the deployment code. As a result, the transaction rolls back even though the deployment process is not aware that an error has occurred. Certain transaction time outs can also lead to similar behavior.

One scenario is caused by APAR PM83253. The WebSphere Application Server Transaction Service does not properly throw an error when the client inactivity time-out occurs. With this APAR, the deployment properly recognizes that a timeout has occurred and it throws an error that warns you that the timeout has occurred. The client inactivity time out causes the transaction to rollback if the deployment process takes too long.

Resolving The Problem

With PM83253, you get an install failure error to help identify that an issue has occurred. You see the following error instead of the success message:
CWLLG2164E: Install did not complete successfully because of an unexpected exception. Error:  <Temp folder>\import.zip5970746069020999476                      
com.lombardisoftware.client.delegate.BusinessDelegateException: UOWManager transaction processing failed; nested exception is com.ibm.wsspi.uow.UOWException: javax.transaction.RollbackException: Global transaction rolledback from subordinate


This change means that an error on another server caused the transaction to fail. If you have confirmed that this issue was due to the client inactivity timeout on the Performance Data Warehouse Server, then you need to increase the value. You should set the timeout value to a value that is larger than the time it takes to finish the deployment process. For more information on the client inactivity timeout, see the Configuring transaction properties for an application server document.


If there is another issue that causes the transaction to rollback without raising an error, then you might need to look for other errors in the same thread or enable transaction tracing to further debug your issue.

Subsequent snapshot install attempts might need to occur after a server restart. These attempts might be needed as this behavior can lead to the issue that is described in the Deploying a snapshot for IBM Business Process Manager (BPM) fails with a branch not found error document.

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Product Synonym

BPM

Document Information

Modified date:
15 June 2018

UID

swg21633278