IBM Support

Messaging Engine Will Not Start

Troubleshooting


Problem

The SystemOut.log shows the messaging engine trying to start, but it fails to get a lock on the data store. The following message will be recorded multiple times: CWSIS1593I: The messaging engine, ME_UUID=Hex_number, INC_UUID=Hex_number, has failed to gain an initial lock on the data store.

Cause

In the JDBC section of the SystemOut.log file the following message is found:

DSRA7042W: Oracle does not support the use of version 10 of their JDBC driver with the version of the Java runtime environment that is used by the application server.

Resolving The Problem


Change the Helper class in the data source configuration. The Information Center states:

"You must use the Oracle11gDataStoreHelper with the ojdbc6.jar driver file, regardless of whether you use an Oracle 11g or Oracle 10g database server."

http://www14.software.ibm.com/webapp/wsbroker/redirect?version=v700osgijpa&product=was-nd-mp&topic=rdat_minreqoracle

[{"Product":{"code":"SSEQTP","label":"WebSphere Application Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Service Integration Technology","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"8.5;8.0;7.0;6.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21627451