IBM Support

A NameNotFoundException occurs in the sca/WLE_<clustername>/ActivationSpec log file after migrating to IBM Business Process Manager (BPM)

Troubleshooting


Problem

If APAR JR44382 is not applied prior to migrating the WebSphere Process Server (WPS) Version 7.0 environment to IBM Business Process Manager, you will see a javax.naming.NameNotFoundException sca/WLE_cluster_name/ActivationSpec error after starting the migrated servers.

Symptom

After you migrate WebSphere Process Server Version 7.0 to IBM Business Process Manager, there is a NameNotFoundException exception in the WLE_cluster_name/ActivationSpec log files. This error is issued by the profile_root/installedApps/cell_name/IBM_BPM_Teamworks_cluster_name.ear application.

Cause

The migration utility does not create the required resources. This issue has been recorded as APAR JR44382.

Diagnosing The Problem

You see an error message in the SystemOut.log file during startup of the server whose text is similar to the following text:

[9/18/12 12:29:04:283 EEST] 0000001f RALifeCycleMa E   J2CA0052E: The
lookup of the Activation Specification with JNDI Name
sca/WLE_<clustername>/ActivationSpec failed due to the following exception:
javax.naming.NameNotFoundException: Context: wascell/clusters/<clustername>, name:
sca/WLE_<clustername>/ActivationSpec: First component in name
WLE_<clustername>/ActivationSpec not found. [Root exception is org.omg.CosNaming.NamingContextPackage.NotFound:
IDL:omg.org/CosNaming/NamingContext/NotFound:1.0]
        at com.ibm.ws.naming.jndicos.CNContextImpl.mapNotFoundException(CNContextImpl.java:4378)
        at com.ibm.ws.naming.jndicos.CNContextImpl.doLookup(CNContextImpl.java:1807)
        at com.ibm.ws.naming.jndicos.CNContextImpl.doLookup(CNContextImpl.java:1762)
        at com.ibm.ws.naming.jndicos.CNContextImpl.lookupExt(CNContextImpl.java:1513)
        at com.ibm.ws.naming.jndicos.CNContextImpl.lookup(CNContextImpl.java:645)
        at com.ibm.ws.naming.util.WsnInitCtx.lookup(WsnInitCtx.java:166)
        at com.ibm.ws.naming.util.WsnInitCtx.lookup(WsnInitCtx.java:180)
        at javax.naming.InitialContext.lookup(InitialContext.java:436)
        at com.ibm.ejs.j2c.RALifeCycleManagerImpl.activateEndpoint(RALifeCycleManagerImpl.java:1690)

Resolving The Problem

To resolve this problem, you can create the missing resources manually. Complete the following steps:

  1. Create the destination on the bus.
    1. Start the WebSphere Application Server Administrative Console using the following URL: https://host_name:secure_port/ibm/console. Replace host_name and secure_port with the values for your environment.

    2. Navigate to Service Integration > Buses > SCA.System.cell_name.Bus.

    3. On the right, select Destinations > New.
      • Destination Type: Queue
      • Identifier: sca/WLE_cluster_name.
      • Bus member: messaging_cluster_name

    4. Click Finish.

  2. Create the Activation Specification
    1. Navigate to Resources > J2C Activation Specification > New.

    2. Select the cluster_name as the scope to create the resource.

    3. Set the properties as shown in the following screen shot.



    4. Click Apply and select the Custom Properties on the right side of the window.

    5. Set the properties as shown in the following screen shot. Change the maximum rows on top of the table in the preferences section to show all attributes on one screen. Read all of the properties carefully and change the settings as shown in screen shot.





      The cluster_name variable is the name of the cluster that is shown in the stack trace. The messaging_cluster_name variable is the name of the cluster that is holding the messaging engines for SCA.System bus.

[{"Product":{"code":"SSFTN5","label":"IBM Business Process Manager Advanced"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Migration","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"8.0.1;8.0;7.5.1.1;7.5.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

BPM WPS

Document Information

Modified date:
15 June 2018

UID

swg21626780