IBM Support

How to avoid potential loss of previous configuration when upgrading to a new version of Content Analytics with Enterprise Search or OmniFind Enterprise Edition

Troubleshooting


Problem

Depending on the directory structure of the previously installed version of IBM Content Analytics with Enterprise Search or OmniFind Enterprise Edition, configuration files and indexes in the data directory might be deleted when you upgrade to a newer product version. This document describes how to avoid the deletion of data in this case.

Cause

This problem can occur when the data directory (ES_NODE_ROOT) is located under the installation directory (ES_INSTALL_ROOT) at a depth that is deeper than one level.

For example, if your existing version is installed with the following directory layout, configuration files and indexes are deleted when you upgrade to a newer product version:

ES_INSTALL_ROOT=C:\Program Files\IBM\es
ES_NODE_ROOT=C:\Program Files\IBM\es\subfolder1\esadmin
or
ES_NODE_ROOT=C:\Program Files\IBM\es\subfolder1\subfolder2\esadmin

If the data directory is installed directly under the ES_INSTALL_ROOT directory, the data is preserved when you upgrade. For example, the following directory layout is not affected by this problem:

ES_INSTALL_ROOT=C:\Program Files\IBM\es
ES_NODE_ROOT=C:\Program Files\IBM\es\esadmin

If the directory structure does not match the required conditions, the installation program deletes the data directory when upgrading.

Diagnosing The Problem

Check whether the data directory (ES_NODE_ROOT) is located under the installation directory (ES_INSTALL_ROOT) at a depth that is deeper than one level.

Resolving The Problem

Follow these steps when running the installation program to upgrade to a newer version of the product. The steps are necessary for every Content Analytics with Enterprise Search or OmniFind Enterprise Edition server.

  1. Log in to the server as the root user and place the patch under a directory that the root user can read. For information about the patch, contact IBM Software Support.
  2. Launch the installation program and click OK in the splash screen.
  3. Run the following command, ensuring that the installation window is still open:

    # ps -ef | grep install

  4. The following line is displayed in the output. Take note of the temporary directory under /tmp in the output. In this example, it is /tmp/install.dir.757924. This directory will be referred to as <tmp> in these instructions. Also take note of the command line itself, such as /tmp/install.dir.757924/AIX/resource/jre/jre/bin/java com.zerog.lax.LAX /tmp/install.dir.757924/temp.lax /tmp/env.properties.757924)

    root 757924 602236 0 14:48:30 pts/1 0:29 /tmp/install.dir.757924/AIX/resource/jre/jre/bin/java com.zerog.lax.LAX /tmp/install.dir.757924/temp.lax /tmp/env.properties.757924

  5. Go to the <tmp> directory, such as /tmp/install.dir.757924.
  6. Remove the sea_loc file.
  7. Click Cancel and exit the installation program.
  8. Edit the <tmp>/temp.lax file as shown below. You can specify the file names as you like. The standard output and standard error will be logged in these files.

    lax.stderr.redirect=/tmp/temp.20121115.err
    lax.stdout.redirect=/tmp/temp.20121115.out

  9. Run the command shown in step 4 and prepend the Java class path option to launch the installation program again. Insert the -cp option and the following path before com.zerog.lax.LAX, as shown below. The <path_to_the_debug_module> variable is the path to the debug module placed at step 1, and it must be located at the head of the class path. The other two paths are the paths to the original classes.

    /tmp/install.dir.757924/AIX/resource/jre/jre/bin/java -cp <path_to_the_debug_module>:<tmp>/InstallerData:<tmp>/InstallerData/installer.zip com.zerog.lax.LAX /tmp/install.dir.757924/temp.lax /tmp/env.properties.757924

    For example, the entire command line would be as follows:
    /tmp/install.dir.757924/AIX/resource/jre/jre/bin/java -cp /root/patch.zip:/tmp/install.dir.757924/InstallerData:/tmp/install.dir.757924/InstallerData/installer.zip com.zerog.lax.LAX /tmp/install.dir.757924/temp.lax /tmp/env.properties.757924

  10. Complete the installation.

[{"Product":{"code":"SS5RWK","label":"Content Analytics with Enterprise Search"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"3.0;2.2;2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}},{"Product":{"code":"SS5SQ7","label":"OmniFind Enterprise Edition"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"","label":"Linux on System z"}],"Version":"9.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 June 2018

UID

swg21624216