IBM Support

Lose focus starting sessions using Java 7 with Host On-Demand

Troubleshooting


Problem

Upgrading to Java 7 on the IBM Rational Host On-Demand clients result in the loss of focus when the session icons are started.

Symptom

After starting a session window, you are unable to type in the screen. You can click on the input field to regain focus and start to type.

Cause

This is a problem caused by Java. Currently all levels of IBM JRE 7 and Oracle Java 7 have this focus issue.

Environment

Any client using Java 7.

Resolving The Problem

Host On-Demand development has a fix for this focus issue and it will be available in HOD 11.0.7 scheduled for early March, 2013.


To be notified when the new service is available, subscribe to receive notifications for Host On-Demand.

You can subscribe from the support portal:
http://www-947.ibm.com/support/entry/portal/Overview/Software/Rational/WebSphere_Host_On-Demand.
  1. Click on Manage all my subscriptions under Notifications.
  2. Sign in using your IBM Web ID. If you don't have one, register for an ID.
  3. Once logged in, click on the Subscribe tab.
  4. Under Software, select Rational. You will be presented with a long list of Rational products.
  5. Select Rational Host On-Demand and any other product you are interested in.
  6. Click on continue at the bottom of the page.
  7. Next, select the frequency of the notifications. Weekly is probably frequent enough.
  8. Select Downloads and drivers, Fixes, Flashes, and Problem solving information.
  9. Click on Submit.

WORKAROUND:

  • You can use the existing JRE and click in the Input field to gain focus
    or
  • Use Java 6

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Document Information

Modified date:
02 August 2018

UID

swg21623392