IBM Support

Error 30107 when attempting to log into Information Server DataStage

Troubleshooting


Problem

You receive Error 30107 when attempting to log into Information Server DataStage

Cause

Error 30107 is usually caused by insufficient user permissions, but it can also be caused by a DataStage routine missing from the DataStage catalog area.

Resolving The Problem

Try logging in to DataStage as the dsadm user. If this succeeds, the problem was caused by insufficient user permissions for the non-dsadm user. Add the non-dsadm user to dsadm's primary group.
If logging in as the dsadm user does not succeed, continue with the following:

Open a putty window (or command window if using Windows) as the dsadm user
cd to the DataStage DSEngine directory
If using unix/AIX/Linux, source the dsenv file:
. ./dsenv

touch errlog
chmod 666 errlog

bin/uvsh
LOGTO projectname (where projectname is any existing project name)

DSD.RUN jobname (where jobname is any existing job name)

Check for your screen for errors similar to these:

$DS.GETPID is not a Datastage Basic file
$DS.SIGNAL is not in the catalog space.

If you see any errors like those above, perform the following:

LOGTO UV

CATALOG.GCI $DS.xxxxx (enter the routine name mentioned in the error on your screen)

[{"Product":{"code":"SSZJPZ","label":"IBM InfoSphere Information Server"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.1;8.7;8.5;8.1;8.0.1;7.5","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
16 June 2018

UID

swg21621428