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** Troubleshooting ** Slow performance when using Trial Balance with Drilldown

Troubleshooting


Problem

User clicks "Group - Reports - Trial Balance with Drilldown". User runs report. The performance is poor.

Symptom

There are many possible causes for slow performance *generally* in Controller.
  • See other Technotes for examples, such as 1347497.
 

This Technote specifically concentrates on the scenario where (in general) the Controller performance is good. Instead, the *only* area of performance concern is when running Trial Balance with Drilldown (TBWD) reports.

Cause

There are several possible causes for slow TBWD performance:
  • Scenario #1 - Code production problem (APAR PM61165) in some older versions of Controller (before 10.1.1305)
  • Scenario #2 - Controller client running older version compared with Controller application server.
    • In one real-life example, the customer had upgraded their application server to Controller 10.1.397, but had forgotten to upgrade the client device. The client device was still using version 10.1.377, which was causing the problem.
  • Scenario #3 - Out of date (poor) SQL database indexes
  • Scenario #4 - Code production problem (APAR PM90922) in Controller 10.1.1
  • Scenario #5 - User has accidentally clicked the preview (run) button more than once
    • See separate IBM Technote #1980600 for more details.
  • Scenario #6 - Code production problem (APAR PI60486) relating to fragmented SQL indexes (on the table XSUMALL)
    • See separate IBM Technote #1980929 for more details.
  • Scenario #7 - A different user has previously imported data (for example via 'flat files' or 'staging tables') which had an import specification that had 'Track Data' enabled.
    • See separate IBM Technote #2010589 for more details.
  • Scenario #8 - Defect (APAR) when using DB2, which exists in the following Controller versions:
    • Controller 10.3.1100.190 (and earlier)
    • Controller 10.4.0
      • See separate IBM Technote #0795664 for more details.

Resolving The Problem

Scenario #1
Upgrade to Controller 10.1.1305 or later.
  • See separate IBM Technote #1589186 for more details.

Scenario #2
Ensure that your user's client device (e.g. Citrix server) has been upgraded to the correct Controller client (in addition to the application server).

Scenario #3
Ensure your SQL database is regularly optimised.
  • See separate IBM Technote #1580393 for more details.

Scenario #4
Upgrade to Controller 10.2.0 or later.
  • See separate IBM Technote #1638219 for more details.

Scenario #5
Ensure that you only click the 'Preview' (run) button once.
  • See separate IBM Technote #1980600 for more details.

Scenario #6
As a workaround, run the following script: ALTER INDEX ALL ON xsumall REBUILD
  • See separate IBM Technote #1980929 for more details.
Scenario #7
Disable ('untick') the 'track data' box for all the import specifications that are in production (in other words, they have been built/finished/tested).
  • See separate IBM Technote #2010589 for more details.

Scenario #8
Upgrade to a later version of Controller.
  • See separate IBM Technote #0795664 for more details.

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Document Information

Modified date:
20 January 2020

UID

swg21619672