IBM Support

Some requests are missing in the reports

Troubleshooting


Problem

By default, the requests will not be captured when their execution takes place before the actual Servlet entry point.

Cause

ITCAM for AD always monitors Servlets and EJBs and considers them as the entry point of a user-transaction. These are called the "edge-requests" and a transaction will be monitored only if it starts with one these.

In Servlet architecture, there is a feature called "Filters". These filters can be added before the actual Servlet execution takes place. Typically, these filters are used to do other types of work, like logging, security, etc. that are not directly related to the business logic that the Servlets will do. There can be multiple filters - each one doing a specific work like logging, checking authorization, etc. - and each filter passes the execution to the next one and finally to the main Servlet. A filter can also decide not to pass on the execution flow down the chain if necessary (for example, if an authorization fails or due to some other failure).

Servlet filter 1 -> Servlet filter 2 -> ... -> Servlet

By default ITCAM does not monitor what the filters are doing as they are not considered pure "application" artifacts. As a consequence, if the requests are executed from these filters that manage all the work and do not pass control to the main Servlet, you will have to enable the Servlet filter monitoring to capture the monitoring events.

All other instrumentation types (EJB, JNDI, JDBC, JMS, CTG, etc.) should be enabled by default.

Resolving The Problem

In order to enable the Servlet filter monitoring you can add the following property in the <DC_HOME>/runtime/<server>/custom/toolkit_custom.properties:

com.ibm.tivoli.itcam.toolkit.ai.enableservletfilter=true

Restart the application server after adding the above property.

[{"Product":{"code":"SSDTFJ","label":"Tivoli Composite Application Manager for Application Diagnostics"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ITCAM for APPLICATION DIAGNOSTICS Agent for WebSphere","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"7.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21619465