IBM Support

An IBM Business Process Manager (BPM) exception occurs when adding an LDAP user or group to a Lombardi internal group

Troubleshooting


Problem

Although you can see LDAP members and groups, they cannot be successfully added to Lombardi user groups.

Symptom

You might encounter an exception that is similar to the following text:

0000002d exception     E com.ibm.ws.wim.
adapter.urbridge.URBridge get CWWIM4505E  Virtual member manager failed to get the 'uid=username,o=twinternal' entity: 'com.ibm.websphere.wim. exception.WIMApplicationException'.


where the username variable is the name of the administrator user that is used to add members to groups.

Cause

This issue has been identified as a product defect under APAR PM56913.

Diagnosing The Problem

You can diagnose this problem by carefully reviewing the exceptions that are generated when you add members to the Lombardi database. If your administrative user has any capital letters in it and the error shows the username in all lower-case letters, the capitalization is the cause of the error that you are encountering.

Resolving The Problem

This issue is fixed by installing the fix for PM56913, which is included in WebSphere Application Server Version 7.0.0 Fix Pack 25. However, you must change a parameter to enable the code fix.

This APAR introduces the sib.processor.userNameCaseSensitive custom property. When you set this custom property to true, it ensures that the username value is not explicitly converted to a lower-case value. It retains the username value "as is" and then validates the username value against the repository.

You need to set this property as a custom property for the Messaging Engine. To set this property through the administrative console, click Service integration > Buses > [Content Pane] bus_name > [Topology] Messaging engines > engine_name > [Additional Properties] Custom properties.

[{"Product":{"code":"SSFTDH","label":"IBM Business Process Manager Standard"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Security","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.5.1.1;7.5.1;7.5.0.1;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSFTBX","label":"IBM Business Process Manager Express"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Security","Platform":[{"code":"PF016","label":"Linux"},{"code":"","label":"Linux zSeries"},{"code":"PF033","label":"Windows"}],"Version":"7.5.1.1;7.5.1;7.5.0.1;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSFTN5","label":"IBM Business Process Manager Advanced"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Security","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"","label":"Linux zSeries"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.5.1.1;7.5.1;7.5.0.1;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21617395