Troubleshooting
Problem
Perfmon output can be used to check for Disk performance bottlenecks
Cause
Poor Disk performance
Diagnosing The Problem
Perfmon has many settings. Windows help or internet searches can provide instructions how to configure perfmon to display the desired information.
Resolving The Problem
The following categories can be configured and monitored:
Physical Disk: Avg. Disk Sec./Transfer
Should be less than 25ms
Physical Disk: Avg Disk Queue Length (This may be a default - blue line below)
Optimal when value is 2-3 times the number of disks in the array
Physical Disk: Avg Disk Bytes/Transfer
The Stripe size for the array should be at least the average of this counter
Physical Disk: Disk Bytes/sec
Summary of all these attached to a given controller should be less than 70% of the theoretical throughput
Physical Disk: Split IO/sec
A non-zero value seen here for this counter indicates disk fragmentation.
Example Perfmon screenshot:
[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.2;6.3","Edition":"Edition Independent","Line of Business":{"code":"LOB26","label":"Storage"}}]
Product Synonym
TSM ADSM ITSM IBM Spectrum Protect
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21615403