IBM Support

Remedy Gateway loses connection to ARS Server

Question & Answer


Question

How do we reconnect the gateway to Remedy when it loses a connection ?

Cause

Given the fact that the gateway uses the TCP protocol to connect to the BMC Remedy Server, users want to know if it is possible to force the gateway to reconnect to Remedy once it comes back online

Answer


There is no need force the gateway to reconnect as this is hard coded into the gateway binary.

Note :
Once the gateway makes an API call and establishes a connection with the remedy server it will simply wait for it to come online again before sending the next API call to the relevant schema it is using.

If the gateway goes down for any reason, you are best advised to use PA to restart it.

[{"Product":{"code":"SSSHTQ","label":"Tivoli Netcool\/OMNIbus"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Remedy ARS Gateway","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"7.4.0;7.3.1;7.3.0;8.1.0","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

nco_g_remedy

Document Information

Modified date:
17 June 2018

UID

swg21614181