IBM Support

Collecting Data: for Tivoli Business Service Manager – OutOfMemory Error

Troubleshooting


Problem

Information to collect in order to help analyze and understand a TBSM Out of Memory issue.

Symptom

Performance issues. OutOfMemory error.

Cause

Collecting this information before calling IBM support will help you understand the problem and save time analyzing the data

Resolving The Problem

Provide the following items:

1) Provide a concise problem description that includes (things like) a timeline, sequence of events, any error messages issued, and a scenario on how to recreate the problem you encountered.

2) Send TBSM server Operating System (OS) information, (i.e.,Type, Version, Memory).
As outlined in the OS Technote.

3) Send TBSM version information as outlined in Version Technote

4) Send TBSM Server's current initialHeapSize and maximumHeapSize settings, as outline in JVM settings technote.

5) Enable garbage collection (GC) logging. as outlined in enable GC logging technote.

6) Download the latest Collect_Logs Utility for TBSM (Version 6.1 OR 4.2.1).
(If TBSM 6.1.1, OR 6.1 FP1 or greater, OR 4.2.1 FP3 or greater, skip to next at #7).

7) Once the latest Collect_log Utility is installed, run the collection. (How-to instructions for using collect_logs are defined technote from #6.)

    execute the command as follows:
      On Unix: <installdir>/tbsm/bin/collect_logs
      On Windows: <installdir>\tbsm\bin\collect_logs.bat

    NOTE: Read the on-screen prompts. User interaction is required to collect DE and ITM Agent data. These two collection points can be bypassed by pressing the "Enter" key at each of the two prompts.

    Results :
    After running the utility on the TBSM server(s), the result will be a single zip file on each of the servers where the utility is run. Execution time and zip file size will depend on the amount of data stored on the TBSM server's various logs directories.
      Unix: <installdir>/tbsm_logs_20160612095959.zip
      Windows: <installdir>/tbsm_logs_20160612100212.zip

    You should end up with a zip file named similar to what is shown above, for each of the servers where you ran collect_logs. The collection will include server.xml files, javaheap*.txt files, and server logs in TIPProfile/logs/server1 directory and TBSMProfile/logs/server1 directory.
8) Please also collect the latest core files, and heapdump files. (i.e., javacore*.phd, heapdump*.*, and Snap*.trc files). These should be located:
    Dashboard: <TIP HOME>/profiles/TIPProfile
    Data Server: <TIP HOME>/profiles/TBSMProfile

    Since these files can be quite large, please use compression before submitting data.
9) Send output to support
    To send information to IBM, please first rename any file so they begin with your PMR number (which is an 11 digit number like 99999,999,999). Then upload your file(s) using a web browser through the following link:

    http://www.ecurep.ibm.com/app/upload

[{"Product":{"code":"SSSPFK","label":"Tivoli Business Service Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"4.2.1;6.1;6.1.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21613320