IBM Support

Viewing tasks in Process Inspector for IBM Business Process Manager (BPM) results in date error

Troubleshooting


Problem

When you view tasks in the Process Inspector, an error occurs due to date formatting. The date format should be "YYYY-MM-dd," but it is interpreted sa "YYYY-dd-MM."

Cause

The locale for the database user is not English. If a non-English locale is selected for the database user, it changes the date formats on SQL SELECT statements that it passes back to the client.

Environment

This issue occurs in IBM Business Process Manager environments using a Microsoft SQL Server as the database.

Diagnosing The Problem

Task and instances where the day is greater than twelve (12) generate an error in the process inspector.


The following errors occur in the SystemOut.log file:
 0000005f servlet       E com.ibm.ws.webcontainer.servlet.ServletWrapper service SRVE0014E: Uncaught service() exception root cause BPMInspectorRestFacade: javax.servlet.ServletException: javax.servlet.ServletException: com.ibm.processinspector.rest.ProcessAdminRestException: {"status":"error","Data":{"status":"error","exceptionType":"com.ibm.bpm.wle.api.UnexpectedFailureException","errorNumber":"CWTBG0019E","errorMessage":"CWTBG0019E: Unexpected exception during execution.","errorMessageParameters":null,"programmersDetails":"StatementCallback; bad SQL grammar [select count (distinct t.bpd_instance_id) from lsw_task t with (nolock) inner join lsw_bpd_instance i with (nolock) on t.bpd_instance_id = i.bpd_instance_id left join lsw_bpd_status_codes istatus on i.execution_status = istatus.status_id  where ( ( i.last_modified_datetime > CAST ('2012-08-21 02:00:00.000' AS datetime) AND istatus.name = 'Active' ) ) ]; nested exception is com.microsoft.sqlserver.jdbc.SQLServerException: ... 34 more

Resolving The Problem

To resolve this issue, change the user location of the database to English in the Microsoft database configuration. Complete the following steps:

  1. Shut down all IBM Business Process Manager servers for this environment.

  2. Log into the Microsoft Management Studio.

  3. Locate your database user in the Security > Logins directory.

  4. Select Properties.

  5. Change the default language to English.

  6. Save the settings. (See the attached image).

  7. Restart IBM Business Process Manager servers.



[{"Product":{"code":"SSFTDH","label":"IBM Business Process Manager Standard"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Databases","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.0;7.5.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSFTBX","label":"IBM Business Process Manager Express"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Databases","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.0;7.5.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSFTN5","label":"IBM Business Process Manager Advanced"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Databases","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.0;7.5.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21612759