IBM Support

Error occurs saving a dcube when library path has changed from drive letter to UNC on the server: [FS00119] FileGet/FilePut error (code: 10103)

Troubleshooting


Problem

The following error occurs saving a dcube when the library path has changed from drive letter to UNC on the server. Without making any changes to the dcube and selecting save, the error will occur. The error occurs for only 1 dcube. The dcube can be saved when using Analyst on a workstation. However, when using Analyst directly on the Admin Server, the error occurs. Changing the library path to drive letter instead of UNC, the dcube can be saved from the server. Virus scanning on the library objects is turned off. There are no network latency issues. The size of the dcube is not large. The analyst library is located on the server where the error is occuring.

Symptom

Error:
The operation failed. When reporting the problem please include the following information:
[FS00119] FileGet/FilePut error (code: 10103)
Code: FS0119 at DCubeSave[8]
OK

Cause

The size of the h2 file(the structure file) that represents this Dcube is large

Resolving The Problem

Decrease the size of the h2 file by turning auditing on the problem Dcube.

1. In Analyst select File>Library>Dcubes
2. Select the Dcube and move it to the bottom box (using the arrow down)
3. Right click on the Dcube in the bottom box and select Set Audit
4. The Dcube will now save properly.

NOTE:
The original size of the h2 file was: 116,370KB
After turning auditing on and saving the Dcube, the h2 file is now: 16KB

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Document Information

Modified date:
15 June 2018

UID

swg21612322