IBM Support

Attempt to submit or modify a record using a REST URI results in "internal error"

Troubleshooting


Problem

When you attempt to submit or modify a record using a Representational State Transfer (REST) Uniform Resource Identifier (URI) on IBM Rational ClearQuest Web, it may result in an "internal error" message on the log on page if the user account has not logged on the Rational ClearQuest Web before.

Symptom

You can use a REST URI similar to that follows to submit or modify a record on Rational ClearQuest Web.

http: //192.168.0.1/cqweb/restapi/7.0.0/SAMPL/RECORD?format=HTML&recordType=Defect&fieldsXml=<Field><Name>Headline</Name><Value><![CDATA[sample record]]></Value></Field><Field><Name>Severity</Name><Value><![CDATA[1-Critial]]></Value></Field>&autoSave=false

If it is the first time that you use your user account on the Rational ClearQuest Web, you may see an "internal error" message after you enter your user name and password.

Cause

Rational ClearQuest Web incorrectly tries to load the user profile, which does not exist because the user account has not logged on the Rational ClearQuest Web before.

Resolving The Problem

You can avoid this problem in the following ways.

  • Log on Rational ClearQuest Web in the normal way once first.
  • Use Rational ClearQuest Web 7.1.2 or newer version.

For more information about REST URI, refer to Rational ClearQuest Information Center.

[{"Product":{"code":"SSSH5A","label":"Rational ClearQuest"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Web Client (7.1)","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.1.1.9;7.1.1.8;7.1.1.7;7.1.1.6;7.1.1.5;7.1.1.4;7.1.1.3;7.1.1.2;7.1.1.1;7.1.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21608446