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Collect troubleshooting data for IMS problems in CICS TS for z/OS

Troubleshooting


Problem

You are having an IMS problem in CICS Transaction Server for z/OS (CICS TS). You would like to know what documentation you must collect (MustGather) so that the CICS Support team can diagnose your problem. If you gather this documentation before contacting support it will expedite the troubleshooting process, and save you time.

Cause

A CICS task can be waiting for the CICS IMS task to complete its work in IMS or a CICS task can be waiting for an open thread TCB to become available in CICS.

Resolving The Problem

For the most up-to-date documentation, refer to Collecting CICS troubleshooting data (MustGather) for IBM Support in the CICS TS documentation. You will find the General information you should gather for every type of problem followed by the Component-specific information which includes Troubleshooting data for IMS problems.

The following is the original MustGather information:

Collect this MustGather data before contacting IBM Support:








Collecting general information for all problems

If you have already contacted IBM Support, you can continue on to the component-specific MustGather information. Otherwise, go to Collect troubleshooting data for CICS products - Read first.







Collecting data for IMS wait problems


Required (MustGather) data:
  • If possible, enter the following IMS command from the console, SDSF, or by using the CICS transaction CDBM:
    /DISPLAY ACTIVE
  • MVS system dump of both CICS and IMS taken when the IMS wait is occurring. Enter the following MVS command followed by the reply to capture the dump:
    DUMP COMM=(dumpname)
    R
    yy,
    JOBNAME=
    (*MASTER*,
    cicsjob,XCFAS,ssnmIRLM,ssnmCTRL,ssnmDBRC,ssnmDLI),
    SDATA=
    (RGN,CSA,SQA,LPA,LSQA,SWA,PSA,ALLNUC,XESDATA,TRT,GRSQ,SUM)

    where dumpname contains both the CICS jobname and IMS subsystem, yy is the number of the message, cicsjob is the cics region and ssnm is the subsystem name of the IMS members.
  • MVS system Trace that is included in the MVS system dump when MVS internal system trace is set on. You can enter MVS TRACE command TRACE ST,128,BR=OFF and TRACE MT,256K to ensure that the system trace is large enough.
  • CICS internal trace that is included in the MVS system dump when tracing is active. Level 1-2 tracing should be on for the RI component for CICS TS V3.1 and above. When possible level 1 tracing should be on for all other CICS components and the trace size should be 10240K.


Optional (MustGather) data:
  • If possible, enter the following three MVS Display commands:
    D A,ALL
    (or D A,ssnm* or D A,IRL*)
    D GRS,CONTENTION
    D OPDATA
  • CICS message log.
  • CICS auxiliary trace or GTF Trace up until the time that the wait occurs This can be helpful when attempting to identify the cause of the wait and it is necessary to keep a record of events leading up to the wait over a long period of time.








Troubleshooting hints and tips

Diagnostic tips:
  • Review the logs and dumps generated at the point of failure.
  • Search the CICS support site for known problems using symptoms like the message number and error codes.
  • If you find a fixing PTF, see Ordering CICS products and maintenance for the options that are available to order CICS maintenance.
  • Gather the documentation and work with the CICS support team to resolve your problem.

Learn more about IMS:


Exchanging data with IBM Support
  1. See Exchanging information with IBM Technical Support for FTP and email instructions using the IBM Enhanced Customer Data Repository (ECuRep).

  2. Go to the Service Request page to open or update a problem. If you have a SoftwareXcel enterprise edition for zSeries contract, you can also ask a non-defect usage questions.

    Always update your Service Request (problem record) to indicate that data has been sent.

If you need to speak to an IBM technical support representative call your country representative. If you need to speak to an IBM technical support representative in the US, call 1-800-IBM-SERV.

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Product Synonym

CICS/TS CICS TS CICS Transaction Server

Document Information

Modified date:
15 June 2018

UID

swg21607280