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Error while configuring the ITCAMfAD Websphere agent

Troubleshooting


Problem

WASX7448E error complaining of being unable to write to wsadmin.traceout

Symptom

The complete error
WASX7448E: The trace file cannot be written to location
/opt/IBM/WebSphere/AppServer/profiles/<profile>/logs/wsadmin.traceout .
Please specify a different location with -tracefile option.

Cause

Locked file

Diagnosing The Problem

This message was seen in the logs:
!MESSAGE Error reading configuration:
/opt/IBM/WebSphere/AppServer/profiles/<profile>/configuration/org.eclipse.osgi/.manager/.fileTableLock (Permission denied)

Resolving The Problem

The Websphere Application Server instance was restarted. This released a lock being held. Subsequently, the agent configuration succeeded.

[{"Product":{"code":"SSDTFJ","label":"Tivoli Composite Application Manager for Application Diagnostics"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ITCAM for APPLICATION DIAGNOSTICS Agent for WebSphere","Platform":[{"code":"PF016","label":"Linux"}],"Version":"7.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
19 December 2019

UID

swg21600590