IBM Support

Worklight Server Installation fails because the installation directory is not empty

Troubleshooting


Problem

When a new installation begins and points to the same location, IBM Installation Manager detects files that are left over from the previous installation, triggers an error about the directory not being empty, and the installation does not proceed.

Cause

This problem is caused by a previous installation not removing all the files during the uninstall process. It might be just a single backup file, but could also be files related to the database being used.

Resolving The Problem

There are two workarounds. 

  • Erase the file manually

    or

  • Select a different directory for the installation.

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Document Information

Modified date:
17 June 2018

UID

swg21600021