Troubleshooting
Problem
Unable to login to two applications simultaneously with Rulerunner in IBM Datacap Taskmaster Capture. Logging into the second application generates the error: Unable to connect to the Engine DB.
Symptom
Depending on the version, the Taskmaster Server log may show one of the following:
- 12/16/13 15:14:37.862 2 12dc Database ID 'Admin' is duplicated for 'PROVIDER=MSSQL;DSN=sqlserver;CATALOG=FlexAdm;UID=myuser;PWD=******;DBNTA=;' and 'PROVIDER=MSSQL;DSN=sqlserver;CATALOG=APTAdm;UID=myuser;PWD=******;DBNTA=;'. Thread: 12dc
- Database index 156 is the same for 'C:\Datacap\Flex\FlexAdm.mdb' and 'C:\Datacap\APT\APTAdm.mdb'. Thread: 8dc
Cause
Taskmaster Server tracks database connections to the server using the db_index column stored inside the admin and engine databases. If creating a new application or deploying a configuration such that the db_index values are not unique across all applications, login issues may result.
Resolving The Problem
To resolve, do the following for each application running on the Taskmaster Server.
- Open the admin database.
- In the admininfo table, note the value of db_index.
- If the value is a duplicate of the value used in a different admin database, change the value to any other random 3-digit number such that it is unique for this database.
- Close the admin database and open the engine database.
- In the enginfo table, check the value of db_index and change it if necessary, so that it is the same as the value in the adminfo table. In older versions these two values had to match. They no longer need to match within an application, but the requirement that they be unique across applications still applies. So it is still good practice to match the adminfo and enginfo values to minimize the possibility of conflicts.
- If the value of db_index is changed, edit the queue table in the engine database and change the value of qu_admDB to the new value for all records.
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Document Information
Modified date:
19 August 2022
UID
swg21599801