IBM Support

"CRITICAL ... SystemServerNotFound ... Could not login to TM1" when using FAP

Troubleshooting


Problem

User launches "IBM Cognos FAP" from the start menu. The Controller "Financial Analytics Publisher" (FAP) Window appears. User starts a publish. User clicks the 'logs' tab. After a few seconds, an error appears.

Symptom

FAP Client:
Inside the "FAP Client", inside the 'logs' section there is an error with 'Severity' set to "CRITICAL". The Description is similar to:

    Could not login to TM1, host: <servername>,
    server name: <TM1_service_servername>, user name: <domain\username>

When the mouse is hovered over this error, the following message pops up:
    SystemServerNotFound

Cause

There are several causes for the generic error 'Could not login to TM1'.

  • TIP: For more examples, see separate IBM Technote #1664572.

This Technote specifically relates to the scenario where the TM1 Server has been restarted. This has caused the FAP<->TM1 communication to become invalid.

Real-life example:
In one real-life customer example, the TM1 server had automatically restarted/rebooted itself (e.g. because of automatic Microsoft patch updates).

Resolving The Problem

If servers/services are restarted (or server machines rebooted) you have to restart servers/services it in a specific order (to keep the FAP-TM1 communication in valid state):

  1. Stop the FAPService
  2. Stop the TM1Server
  3. Start the TM1 Server
  4. Start the FAPService

Note:
Each of these steps may require a short amount of time (e.g. two minutes) to complete its task.
  • Therefore, please pause for a short while (e.g. 2 minutes) between each task.

In addition, there is a recommended method to ensure minimal loss of service between reboots
  • Therefore, see separate IBM Technote #1585881 for more information on TM1/FAP reboot best practices.

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Document Information

Modified date:
15 June 2018

UID

swg21599573