IBM Support

MustGather: RFT Adapter Issues with RQM

Troubleshooting


Problem

This document will assist you in collecting the data necessary to diagnose and resolve issues with the IBM Rational Functional Tester (RFT) Adapter with Rational Quality Manager (RQM).

Cause

This MustGather will assist you in collecting the data necessary to help you diagnose and resolve the issue. If you are unable to determine the root cause using the information collected, you should open a PMR with IBM Rational Support for further investigation providing the data collected.

Resolving The Problem

You can use the IBM Support Assistant Lite (ISA Lite) Data Collector tool to quickly collect diagnostic files, such as log files, configuration files or to run traces. This tool is bundled with the Rational Collaborative Lifecycle Management (CLM) products (Rational Quality Manager (RQM), Rational Requirements Composer (RRC) and Rational Team Concert (RTC) 4.x and above. ISA Lite collects information about your Jazz Team Server environment and stores the information in a .zip archive file. If you have a need to open a service request with IBM Rational Support for further assistance, you can send the archive file with the data collection so that they can help diagnose and fix problems.


The information below should be gathered in addition to the normal information and log gathering done by ISA Lite.

  1. Make sure you are using a compatible version of RFT with your RQM server. See the supported versions in the appropriate Rational Quality Manager system requirements list.

    If the current RFT/RQM versions are not compatible, then first make sure you upgrade to supported versions before moving ahead.
  2. If the problem persists even with supported versions, then gather the following information to troubleshoot further:
    1. Does the script execute outside of RQM, run just within RFT?
    2. What exact settings do you have in the RFT Adapter?
    3. Is the test script local to the RFT host or remote, for instance, on a network share some where?
    4. What type of unit under test?
    5. Are the scripts Java based or Visual Basic?

  3. Collect logs for RFT, the RFT Adapter, and the RQM Server.
    1. Rational Quality Manager logs
      • Version 4.x: Use the ISAlist data collector:
        1. Navigate to <jazz_install>\support\ISALite
        2. runISAlite.bat / runISALite.sh
        3. Files will be collected and the tool prompts for data upload directly to a PMR.
      • Version 3: Log locations can be found in the IBM Rational Collaborative Lifecycle Management Information Center under the topic of Location of log files.

      • Version 2: Logs are in the <install-dir> \server\logs folder - all files starting with qm.log (rollovers will have a .1, at the end). For example, C:\IBM\JazzTeamServer\server\logs\qm.log

    2. Turn on RFT logging per technote 1515430 How to enable logging and tracing in Rational Functional Tester 8.2 and later
    3. Turn on RFT Adapter logging per technote 1597847 Enable debug logging of Rational Functional Tester adapter for Rational Quality Manager

Leverage the Jazz Community

The Jazz based products have an active community that can provide you with additional resources. Browse and contribute to the User forums, contribute to the Team Blog and review the Team wiki.
Refer to technote 1319600 for details and links.

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Document Information

Modified date:
16 June 2018

UID

swg21598734