Troubleshooting
Problem
When opening an image attachment of a BPF Case in the image viewer applet, the expected image is not displayed.
Symptom
Rather than the expected image, the following error image displays, saying that:
"
Unable to open document.
Error: ji.net.dh: Your session has timed out, please close the viewer and log back into the system.
Error: Please make sure this file can be accessed and that it is a supported file type.
"
Cause
The Workplace Image Viewer used in BPF is a Java applet. However, the WebSphere 8 defaults prevent the browser from sending a cookie, including the session cookie, when requesting scripting codes such as Javascripts or Java applets.
Resolving The Problem
1. Log into the WebSphere administrative console.
2. Navigate to Servers->Server Types->WebSphere application servers
3. Click the name of the server your BPF runs on. Be default, the name is "server1".
4. Click "Session management" under the Container Settings section.
5. Click the "Enable Cookie" link.
6. Un-check the option of "Set session cookie to HTTPOnly to help prevent cross-site scripting attacks".
7. Click the OK button and then Save the changes.
8. Restart WebSphere server.
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Document Information
Modified date:
17 June 2018
UID
swg21591627