IBM Support

IBM Installation Manager rollback operation fails for IBM Rational ClearCase if the albd service account password has been changed

Troubleshooting


Problem

When doing a Rollback operation using IBM Installation Manager for IBM Rational ClearCase, if the albd service account password that was originally used at install or upgrade has changed, the operation fails with the following message "java.lang.Exception: Albd configuration failed: Invalid credential provided for user."

Symptom

IBM Installation Manager rollback operation fails with this message: java.lang.Exception: Albd configuration failed: Invalid credential provided for user.

Cause

The password stored in IBM Installation Manager does not match the new password for the albd service account. This issue only occurs during a rollback operation where the albd password has been changed after an installation or upgrade has been completed.

Resolving The Problem

To resolve this problem, complete this procedure to specify the new password in the IBM Installation Manager registry files before starting the rollback operation.

  1. Run the following command to encrypt the new password using the IM utility imutilsc:

    imutilsc encryptString <stringToEncrypt>

  2. Replace the encrypted password in the directory <AppData_dir>\IBM\Installation Manager\installed.xml where <AppData_dir> has one of the following values:

    Windows XP and Windows 2003: C:\Documents and Settings\All Users\Application Data 3 Windows Vista, Windows 7 and Windows 2008: C:\ProgramData
    • In the directory, locate this parameter:
      <data key='user.CC_ServerProcessPassword,com.ibm.rational.clearcase.nt_i386' value='<encryptedString>' />
    • Replace the value with the value from the imutilsc tool
  3. Change the encrypted password in installRegistry.xml:
    • Locate this parameter:
      <data key='user.CC_ServerProcessPassword,com.ibm.rational.clearcase.nt_i386' value='<encryptedString>' />
    • Replace the value with the one you got from the imutilsc tool.
  4. Restart IBM Installation Manager.
Note: This issue has been resolved on versions 8.0.0.3 and 7.1.2.7

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.1.1;7.1.1.1;7.1.1.2;7.1.1.3;7.1.1.4;7.1.1.5;7.1.1.6;7.1.1.7;7.1.1.8;7.1.1.9;7.1.2;7.1.2.1;7.1.2.2;7.1.2.3;7.1.2.4;7.1.2.5;7.1.2.6;8.0;8.0.0.1;8.0.0.2;8.0.0.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21589313