Troubleshooting
Problem
User launches Excel. User opens spreadsheet (XLS / XLSX file) containing Controller formulae. User clicks "Add-ins - Controller - Log in". User logs into Controller. User clicks F9 - the report works OK. User again clicks F9 - again everything is OK (no error). After a number (e.g. 9 or 13 or similar) of F9 refreshes, an error appears.
Symptom
The exact error will vary depending on environment. For example:
Office 10 running on Windows 2008 (32-bit):
IBM Cognos Controller Link
Out of memory
[OK]
Office 2007 running on Windows 2003 SP2 (32-bit)
IBM Cognos Controller Link
Exception of type 'System.OutOfMemoryException' was thrown.
[OK]
Cause
There are many different potential causes for similar error messages.
- For more examples see separate IBM Technote #1406746.
This technote specifically relates to the scenario where the cause is a code production problem (APAR 62878) in Controller 10.1.1306 and earlier.
Environment
Client device running Excel 2007 or 2010.
Diagnosing The Problem
Launch 'Task Manager' on the client device. Inside the 'Processes' tab, look at the 'Mem used' column. Notice how memory used by EXCEL.EXE increases (e.g. by approximately 100Mb or so) after each F9 refresh.
- For example, in one real-life example it rose from from less than 200Mb to (eventually) almost 1Gb, before the error appeared (on the 9th refresh).
Resolving The Problem
Workaround:
Either:
- Use Excel 2003 (instead of Excel 2007/2010)
- Or periodically exit Excel 2007/2010 (when repeatedly running/refreshing reports) and re-launch Excel.
Fix:
Upgrade to Controller 10.1.2659 or later.
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21588281