IBM Support

TBSM 6.1 Data and Dashboard servers separated by a firewall.

Troubleshooting


Problem

If you implement the TBSM 6.1 Data and Dashboard servers in a firewall environment with the two servers separated by a firewall, you will find that a connection is attempted from the dashboard server to the data server on a random port and vice versa. If the firewall doesn't allow it, the connection will fail with a message containing: Connection refused to host:

Symptom

The dashboard server does not initialise correctly. No status or config changes are sent to the Dashboard Server. The following error message is displayed in the Data Server logs.


updatepublish 1 com.micromuse.sla.updatepublisher.ClientUpdateHandlerThread run ENTER^ERROR WRITING to client <dashboard host>:17543 we will remove this client updater.
Connection refused to host: <dashboard host>; nested exception is:
java.net.ConnectException: Connection timed out

Note: The error message above will always report the port of the rmi registry, even if the communication is failing when running rmi stubs using a different port. This can be misleading as netstat may show an established connection to port 17543, but TBSM is failing to run rmi stubs on a random port. Check the firewall to see what port communication is failing on.

Cause


rmi communication typically require at least two server ports - one to lookup stub information in the rmi registry and another to run the stub on the remote server.

The rmi registry port is defined with parameter: impact.server.rmiport

On the Data Server this has a default value of 17542 and is stored in $TBSM_HOME/etc/TBSM_server.props
On the Dashboard Server this has a default value of 17543 and is stored in
<INSTALL_DIR>/tipv2/profiles/TIPProfile/installedApps/TIPCell/isc.ear/sla.war/etc/RAD_server.props

By default, a random port used when the running rmi stubs on a remote server. This can cause problems when a firewall exists between the servers if the random port is blocked.

Resolving The Problem

If a firewall exists between the data server and the dashboard server, then the server port used for running rmi stubs may need to be opened and specified.

To specify this port, on the data server, in the file: $TBSM_HOME/etc/TBSM_server.props create the entries:


impact.rmiPortRangeStart=17544
impact.rmiPortRangeEnd=17544

On the dashboard server, in the file: <INSTALL_DIR>/tipv2/profiles/TIPProfile/installedApps/TIPCell/isc.ear/sla.war/etc/RAD_server.props


impact.rmiPortRangeStart=17544
impact.rmiPortRangeEnd=17544

17544 is a suggested port, you can use a different free port value if you prefer. You can also use a range of more than 1 port if needed by Impact.

Note: This port should be separate from the impact.server.rmiport which is used for the rmi registry.
Note: This port must be open both ways in the firewall

[{"Product":{"code":"SSSPFK","label":"Tivoli Business Service Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"6.1;6.1.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21580697