Troubleshooting
Problem
How can you recover from errors, err = -951: oserr = 0 or Informix -951, ISAM 0, when using IBM Rational Synergy?
Symptom
This issue has been seen when running ccmsrv status and the command lists zero databases and there are errors in the Informix log file:
Get Shadow Password for user [informix] failed!
Check for password aging/account lock-out.
listener-thread: err = -951: oserr = 0: errstr = informix@hostname: Incorrect password or user informix@hostname is not known on the database server.
It has also been seen where the database is trying to be accessed
Serious: Cannot open database '/data/ccmdb/ibm/db'.
Warning: Informix: Incorrect password or user ccm_root@ibm is not
known on the database server.
(Function dbs_open, Informix -951, ISAM 0).
To start up the session in repair mode, please set START_IN_REPAIR_MODE
environment variable to 1.
Cause
The Informix userid is locked out of the system and or the ccm_root userid as well.
Environment
Synergy database environment running Informix.
Diagnosing The Problem
Check the Informix log for the errors.
Resolving The Problem
Restore a valid non-null password to the Informix user and or the ccm_root user.
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Document Information
Modified date:
22 December 2020
UID
swg21580281